1080: 数组元素的插入
Time Limit: 1 Sec Memory Limit: 128 MBDescription
在一个数组的第x个位置插入一个新的数y
Input
有四行 第一行有一个整数n ( 5 <= n <= 10 ) 第二行有n个整数 第三行有一个整数x,为要插入的位置 第四行有一个整数y,为要插入的整数
Output
更新后的数组
Sample Input
5
7 2 3 4 5
2
9
Sample Output
7 9 2 3 4 5
HINT
Source
#include<iostream>
using namespace std;
main()
{
int n,a[100],x;
cin>>n;
for(int i=0;i<n;i++)
{
cin>>a[i];
}
cin>>x;
for(int j=n-1;j>=x-1;j--)
{
a[j+1]=a[j];
}
cin>>a[x-1]; //即为插入的数y
for(int k=0;k<=n;k++)
{
cout<<a[k];
if(k!=n)cout<<' ';
}
}