HDU1045 Fire Net DFS搜索 AC代码

题目
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.
Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
Sample Input
4
.X…

XX…

2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4




0
Sample Output
5
1
5
2
4

题目大意是在网格内放置炮台,炮台之间只能由墙壁阻拦,两个炮台不能在同一行或同一列

一开始想了很久不知道该怎么搜索,一直在想着怎么把X隔开的空间表示出来,最后发现,因为只有4*4,可以直接在每一个可放置炮台的位置分别四个方向搜索到墙壁或者出界,如果没遇到其他炮台就可以放置

代码如下

#include<iostream>
using namespace std;
int A[4][4];
int arr[4][2] = { {0,-1},{0,1},{-1,0},{1,0} };	//四个方向搜索
int num[16][2];		//存储可放炮台的坐标
int maxn = 0;
int N;
bool check(int id) {
	int flg = 1, i, j;
	int x = num[id][0], y = num[id][1];
	if (!A[x][y])return 0;	//如果是墙,返回
	for (i = 0; i < 4; i++) {		//四个方向分别搜索 一直搜索到墙或者出界
		int xx = x + arr[i][0], yy = y + arr[i][1];
		while (xx >= 0 && xx < N&&yy >= 0 && yy < N) {
			if (A[xx][yy] == 9) { return 0; }
			else if (A[xx][yy] == 0)break;
			xx = xx + arr[i][0], yy = yy + arr[i][1];
		}
	}
	return 1;
}
int dfs(int n,int pos,int cnt) {
	if (cnt > maxn) { maxn = cnt; }
	if (pos >= n) { return 0; }
	else {
		int i;
		for (i = pos; i < n; i++) {
			if (check(i)) {		//检查该位置是否可以放炮台
				A[num[i][0]][num[i][1]] = 9;	//炮台设为9
				dfs(n, i + 1, cnt+1);
				A[num[i][0]][num[i][1]] = 1;	//恢复原状态
			}	
		}
	}
	return 0;
}
int main() {
	//freopen("input.txt", "r", stdin);
	//freopen("output.txt", "w", stdout);
	while (scanf("%d", &N) != EOF && N) {
		int i, j, idx = 0;
		memset(A, 0, sizeof(A)); memset(num, 0, sizeof(num));
		for (i = 0; i < N; i++) {
			for (j = 0; j < N; j++) {
				char ch = getchar();
				while (ch == '\n' || ch == ' ')ch = getchar();
				if (ch == 'X')A[i][j] = 0;		//墙壁标为0
				else if (ch == '.') {		//可放置位置标为1 并记录坐标
					A[i][j] = 1; num[idx][0] = i; num[idx][1] = j; idx++;
				}
			}
		}
		maxn = 0;
		dfs(idx, 0, 0);
		printf("%d\n", maxn);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值