UVA 644(字符串)

题目:

n encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9
Sample Output 
Set 1 is immediately decodable
Set 2 is not immediately decodable

题目大意:如果二进制形式里有一条是某一条的前缀,则是NOT IMMEDIATELY,否则IMMEDIATELY,以9作为结束。

方法:用QSORT排好序后,用上次学到的STRING 的FING,利用位置返回值判断。

#include<stdio.h>
#include<string.h>
#include<string>
using namespace std;

int comp(const void*a,const void *b)
{
	return strcmp((char*)a,(char*)b);
}
int main () {
	char str1[100][50];
	memset(str1,0,sizeof(str1));
	int z=0;
	int b=1;
	int a=0;
	int i=0;
	int h=0;
	int num=0;
	int f;
	string s1;
	string s2;
	while(gets(str1[z++])) {
		string s=str1[z-1];
	while (s=="9") {
			b=1;
			qsort(str1,z-1,50,comp);
			for(i=0;i<z-2;i++) {
				if(strlen(str1[i])<strlen(str1[i+1])) {
				s1=str1[i];
				s2=str1[i+1];
				f=s2.find(s1);
				if(f==0) {
					a++;
					z=0;
					b=0;
					memset(str1,0,sizeof(str1));
					s="\0";
					printf("Set %d is not immediately decodable\n",a);
					break;
				}
				}
			}
			if(b==1) {
				a++;
				z=0;
				memset(str1,0,sizeof(str1));
				s="\0";
				printf("Set %d is immediately decodable\n",a);
			}
			
	}
	}


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值