AtCoder Grand Contest 020 C - Median Sum (背包问题+bitset )

Time limit : 2sec / Memory limit : 512MB

Score : 700 points

Problem Statement

You are given N integers A1A2, ..., AN.

Consider the sums of all non-empty subsequences of A. There are 2N1 such sums, an odd number.

Let the list of these sums in non-decreasing order be S1S2, ..., S2N1.

Find the median of this list, S2N1.

Constraints

  • 1N2000
  • 1Ai2000
  • All input values are integers.

Input

Input is given from Standard Input in the following format:

N
A1 A2  AN

Output

Print the median of the sorted list of the sums of all non-empty subsequences of A.


Sample Input 1

Copy
3
1 2 1

Sample Output 1

Copy
2

In this case, S=(1,1,2,2,3,3,4). Its median is S4=2.


Sample Input 2

Copy
1
58

Sample Output 2

Copy
58

In this case, S=(58).

题意:序列构成的子集加起来然后求出中位数
思路:背包问题+bitset
#include <iostream>
#include <cstdio>
#include <map>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <set>
#include <bitset>
const int N = 100005;
using namespace std;
typedef long long ll;
int a[N];
int n;
bitset<4000010> f;
int main()
{
    int i,j,k=0;
    scanf("%d",&n);
    f[0]=1;
    for(i=1;i<=n;i++)  //得到n个数构成的集合f,有则为1,无则为0
      {
       scanf("%d",&j);
       f=f|(f<<j);
       k+=j;
       //printf("%d\n",f);
      }
      /*for(int i=1;i<=k;i++)
      {
          if(f[i]==0)
            printf("0\n");
          else
            printf("1\n");
      }*/
    for(i=(k+1)/2;!f[i];i++);//从总值的一半开始找
    printf("%d\n",i);
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值