HDU - 1171 Big Event in HDU(01背包)

55 篇文章 0 订阅
7 篇文章 0 订阅

点击打开题目链接

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43705    Accepted Submission(s): 15030

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

 
 
2 10 1 20 1 3 10 1 20 2 30 1 -1

Sample Output

 
 
20 10 40 40

Author

lcy

Recommend

We have carefully selected several similar problems for you:   1203  2159  2844  2191  1176 

Statistic | Submit | Discuss | Note

题目大意:

给出物品的价值V和数量M,将所有物品分成A,B两份,要求尽量平均且A不小于B。

思路:

分成两堆,其中较小的那一堆的最大值为总价值的一半。所以将背包容量为价值总和的一半,转化成01背包问题。

附上AC代码:

#include<bits/stdc++.h>

using namespace std;
const int maxn = 5000 + 5;
int cnt[maxn];
int dp[250000];
int N, V, M;
int cur, sum;

int main() {
    ios :: sync_with_stdio(false);
    while(cin >> N && N > 0) {
        cur = sum = 0;
        memset(dp, 0, sizeof(dp) );
        memset(cnt, 0, sizeof(cnt) );
        for(int i = 0; i < N; i++) {
            cin >> V >> M;
            for(int j = 0; j < M; j++) {
                cnt[cur++] = V;
                sum += V;
            }
        }
        for(int i = 0; i< cur; i++) {
            for(int j = sum / 2; j >= cnt[i]; j--) {
                dp[j] = max(dp[j], dp[j - cnt[i]] + cnt[i]);  
            }
        }
        cout<< sum - dp[sum / 2] << ' ' << dp[sum / 2] << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值