POJ - 2184 Cow Exhibition (01背包 中 负数的处理)

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 


The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 


Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 
Input
* Line 1: A single integer N, the number of cows 


* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 
Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 


Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output
8
Hint
OUTPUT DETAILS: 


Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 

allowed. 

题意:给出N,接下来是N个牛的体积和价值,求最大体积和与最大价值的和相加的结果,且最大体积和 最大价值和不可以是负数。

思路:0-1背包

1.有了负数的参与,那么我们需要修改DP数组的起始位置,因为考虑到负数的存在,所以DP数组下标

  1—mid 为处理负数的区间 mid—N为处理正数的区间

2.初始化的问题,dp整个数组为一个极小值(负数),起始点为0.

3.正负数时候不同的背包

4.TS的计算,TF通过DP数组可以得到,TS通过DP数组的下标和 起始点的对比得到

#include <iostream>
#include <cstdio>
#include <map>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <set>
using namespace std;
const int mid = 100000;
const int inf = 99999999;
const int  N  = 200005;
int v[105],w[105];
int dp[N];
int main()
{
    int n;
    while(scanf("%d",&n)==1){
       for(int i=1;i<=n;i++)
        scanf("%d%d",&w[i],&v[i]);
       for(int i=0;i<N;i++)  //初始化 因为有负数 所以初始化一个非常小的负数  
        dp[i]=-inf;

        dp[mid]=0;    //最开始的点
       for(int i=1;i<=n;i++){
        if(w[i]>0)
            for(int k=N-1;k>=w[i];k--)   //正数时候的背包 
                dp[k]=max(dp[k],dp[k-w[i]]+v[i]);
        else
            for(int k=0;k<N+w[i];k++)     //负数时候的背包  
                dp[k]=max(dp[k],dp[k-w[i]]+v[i]);
       }
       int sum=0;
       for(int i=mid;i<N;i++)
        if(dp[i]>0)
            sum=max(sum,dp[i]+i-mid); //dp数组存的是TF,通过i-mid计算TS 
        printf("%d\n",sum);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值