ZOI 1610 Count the Colors 线段树区间更新 (求相同值的段)

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.

Input
The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:
x1 x2 c
x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.
All the numbers are in the range [0, 8000], and they are all integers.
Input may contain several data set, process to the end of file.
Output
Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can't be seen, you shouldn't print it.
Print a blank line after every dataset

Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1




Sample Output




1 1
2 1
3 1
1 1


0 2

1 1

题意:给出n次操作·,每次操作更新区间[l,r]为c,对于每个c有几段

思路:线段树 区间更新+求相同值,看网上的题解说建树必须8000,树是固定的。

从这里学到了建树的时候如果可以直接用memset赋值的话,就不需要构造build函数

#include <iostream>
#include <cstdio>
#include <map>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <set>
const int maxn = 111111;
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long ll;
int  num[maxn<<2];
int  sum[maxn<<2];
int  flag;
void pushdown(int rt)
{
    if(sum[rt]!=-1)
    {
        sum[rt<<1]=sum[rt];
        sum[rt<<1|1]=sum[rt];
        sum[rt]=-1;
    }
}

void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        sum[rt]=c;
        return ;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(L<=m) update(L,R,c,lson);
    if(m<R)  update(L,R,c,rson);
}
void query(int l,int r,int rt)
{
    if(l==r)
    {
        if(sum[rt]>=0&&sum[rt]!=flag)   //利用左右孩子关系统计连续颜色段的个数
            num[sum[rt]]++;
            flag=sum[rt];
            return ;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(l<=m) query(lson);
    if(m<r)  query(rson);

}
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {

            flag=-1;
            memset(num,0,sizeof(num)); //初始化记录数组
            memset(sum,-1,sizeof(sum));//建树
            for(int i=1; i<=n; i++)
            {
                int c,l,r;
                scanf("%d%d%d",&l,&r,&c);
                if(l<r)
                    update(l+1,r,c,1,8000,1);
            }
            query(1,8000,1);
            for(int i=0; i<=8000; i++)
                if(num[i])
                    printf("%d %d\n",i,num[i]);
            printf("\n");
        }
       return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值