根据后序和中序遍历输出先序遍历 (25 分)

本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:

第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:

在一行中输出Preorder: 以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

Preorder: 4 1 3 2 6 5 7

 

#include <iostream>
#include <cstring>
#include <algorithm>
#include <unordered_map>
#include <queue>
#include<map>
using namespace std;

const int N = 40;

int n,count1;
int postorder[N], inorder[N];               //前序遍历,中序遍历
unordered_map<int, int> l, r, pos;          //用哈希表模拟二叉树

int build(int il, int ir, int pl, int pr)
{
	int root = postorder[pr];
	int k = pos[root];                      //得到根节点在中序遍历中的下标
	
	//k大于il表示根节点左边还有节点,即当前根节点存在左子树,下同
	//下面两行是难点,举例解释见图
	if (il < k) l[root] = build(il, k - 1, pl, pl + k - 1 - il);
	if (ir > k) r[root] = build(k + 1, ir, pl + k - il, pr - 1);
	
	return root;
}

void dfs(int root)                          //BFS用来层序遍历输出
{
    if(count1==0)
    cout<<root;
    else cout<<" "<<root;
    count1++;
    if(l.count(root))dfs(l[root]);
    if(r.count(root))dfs(r[root]);
}

int main()
{
	cin >> n;
	for (int i = 0; i < n; i ++ ) cin >> postorder[i];
	for (int i = 0; i < n; i ++ )
	{
		cin >> inorder[i];
		pos[inorder[i]] = i;                //记录中序遍历每个点位置(剪枝)
	}
	
	int root = build(0, n - 1, 0, n - 1);   //参数为中序遍历区间和后序遍历区间
    printf("Preorder: ");
	dfs(root);
	
	return 0;
}

  • 9
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

怀化第二深情

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值