List Leaves

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

翻译在下:

 

解题思路:

 1.创建二叉树,利用结构体数组创建二叉树(静态链表),同我上一篇CSDN文章,不过结构体中有一个参数有所不同,本题是左孩子索引,右孩子索引,与自己的索引(因为此题要求层序打印叶子索引)。

2.树的层序遍历:由题目要求从上至下,从左至右不难想到树的层序遍历。层序遍历方法:队列法。

具体代码如下:

#include<stdio.h>
#define null -1

typedef struct tree
{
	int index;//该节点的索引
	int left;
	int right;//存储左孩子和右孩子的下标
}tree;

tree t[10];
int check[10] = { 0 };
int queue[15] = { 0 };//层序遍历需要用队列
int head=0, tail=0;
int buildTree(tree* t);
void printLeaves(int r);

int main()
{
	int root;
	root = buildTree(t);
	printLeaves(root);

	return 0;
}

int buildTree(tree *t)
{
	int root = null;
	int n,i;
	char cl, cr;
	scanf("%d", &n);
	if (n)
	{
		for (i = 0; i < n; i++)
		{
			getchar();
			scanf("%c %c", &cl, &cr);
			if (cl != '-')
			{
				t[i].left = cl - '0';
				t[t[i].left].index = t[i].left;
				check[t[i].left] = 1;
			}
			else
				t[i].left = null;
			if (cr != '-')
			{
				t[i].right = cr - '0';
				t[t[i].right].index = t[i].right;
				check[t[i].right] = 1;
			}
			else
				t[i].right = null;
		}
		for (i = 0; i < n;i++)
		if (!check[i]) break;
		root = i;
	}
	return root;//返回根节点
}

void printLeaves(int r)
{
	//层序遍历
	queue[tail++] = r;
	int p;//下标位置
	int flag = 1;
	while (head != tail)
	{
		p = queue[head++];
		if (t[p].left != null)
			queue[tail++] = t[p].left;
		if (t[p].right != null)
			queue[tail++] = t[p].right;
		if (t[p].left == null&&t[p].right == null)
		{
			if (flag)
			{
				printf("%d", t[p].index);
				flag = 0;
			}
			else
				printf(" %d", t[p].index);
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值