03-树2 List Leaves

03-树2 List Leaves

分数 25

作者 陈越

单位 浙江大学

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

分析:先找出树的根节点,这很简单,用一个hash数组查找,哪个下标没在输入中,那个就是根节点。然后输出叶子节点,从上到下,从左到右输出,显然是用层次遍历进行输出。

#include <iostream>
#include <vector>
#include <queue>
using namespace std;

typedef int Tree; //左右孩子的类型
#define Null -1 //Null表示结点为空
const int maxn=10; //最大节点数
struct TNode
{
    Tree left,right;
}tree[maxn];
typedef TNode BinTree;
bool hashT[maxn]={0};
Tree CreateTree(TNode *tree); //读出一棵树并返回根结点
vector<int> FindLeaves(Tree root); //得到叶子节点的编号
int main()
{
    Tree root=CreateTree(tree);
    vector<int> ans=FindLeaves(root);
    int flag=0;
    for(int i=0;i<(int)ans.size();++i)
    {
        if(flag==0)
            flag=1;
        else
            printf(" ");
        printf("%d",ans[i]);
    }
    printf("\n");
    return 0;
}

Tree CreateTree(TNode *tree) //读出一棵树并返回根结点
{
    int n;
    scanf("%d",&n);
    getchar();
    char l,r;
    for(int i=0;i<n;++i)
    {
        scanf("%c %c",&l,&r);
        if(l!='-')
        {
            int index=l-'0';
            tree[i].left=index;
            hashT[index]=1;
        }
        else
            tree[i].left=Null;
        if(r!='-')
        {
            int index=r-'0';
            tree[i].right=index;
            hashT[index]=1;
        }
        else
            tree[i].right=Null;
        getchar();
    }
    int root=Null;
    for(int i=0;i<n;++i)
        if(hashT[i]==0)
            root=i;
    return root;
}

vector<int> FindLeaves(Tree root)  //得到叶子节点的编号
{
    vector<int> ans;
    queue<int> q;
    if(root!=Null)
        q.push(root);
    int top;
    while(!q.empty())
    {
        top=q.front();
        q.pop();
        if(tree[top].left==Null&&tree[top].right==Null)
            ans.push_back(top);
        else
        {
            if(tree[top].left!=Null)
                q.push(tree[top].left);
            if(tree[top].right!=Null)
                q.push(tree[top].right);
        }
    }
    return ans;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值