SDNU 1543.Happy Salted Fish Every Day

Description

Salted fish Albert_s is a Sagittarius who will never grow up, especially in front of someone he like. Here's his self-portrait:

One day, he find a wonderful sequence: ……. This sequence consists of and , and its first term equals . Besides, if you see adjacent and equal terms as one group, you will get ……. Count number of terms in every group, you will get the sequence itself. Now, the sequence can be uniquely determined.

Forsaken and Wanderer attracted by this sequence, and they want to know what's the element. Because of something sadness, Albert_s is unable to think now. Would you like to help him?

Input

The first line contains a positive integer T(), denoting the number of test cases.
For each test case:
A single line contains a positive integer n(​).

Output

For each test case:
A single line contains a nonnegative integer, denoting the answer.

Sample Input

2
1
2

Sample Output

1
2
#include <cstdio>
#include <iostream>
#include <queue>
#include <cstring>
#include <string>
#include <cmath>

using namespace std;

#define ll long long

int t, n, sequence[10000000+8], r, ii, j, a;

void solve()
{
    sequence[1] = a = 1;
    sequence[2] = sequence[3] = 2;
    ii = 3;
    j = 4;
    while(j <= 10000000)
    {
        for(int i = 1; i <= sequence[ii]; i++)
        {
            sequence[j++] = a;
        }
        ii++;
        a = 3-a;
    }
}
int main()
{
    solve();
    scanf("%d", &t);//我的想法
    for(int i = 0; i<t; i++)
    {
        scanf("%d", &n);
        printf("%d\n", sequence[n]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/RootVount/p/10327703.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值