SDNU 1309.啤酒和饮料

Description

啤酒每罐2.3元,饮料每罐1.9元。小明买了若干啤酒和饮料,一共花了N元。请你计算他买了几罐啤酒和几罐饮料(罐数为整数)。

Input

一个double型数据N(0<=N<=20000)

Output

输出啤酒和饮料的罐数,如果存在多组结果按照啤酒数从大到小排列;如果没有解答输出"No Solution"

Sample Input

82.3

Sample Output

30 7
11 30
#include <cstdio>
#include <iostream>
#include <cmath>
#include <algorithm>
#include <string>
#include <cstring>
#include <queue>

using namespace std;

#define eps 1e-6

int main()
{
    double n;
    int x, y, m = 0;
    queue<int>colo;
    queue<int>drink;
    scanf("%lf", &n);
    x = n/2.3;
    for(int i = x; i >0; i--)
    {
        y = (int)((n-(i*2.3))/1.9);
        //printf("%d : %lf\n", i, y*1.9+i*2.3);
        if(fabs(y*1.9+i*2.3-n) <= eps)//为什么这个判断得不到正确的结果
            {
                printf("%d %d\n", i, y);
                m++;
            }
    }
    if(m == 0)printf("No Solution\n");
    return 0;
}

 

转载于:https://www.cnblogs.com/RootVount/p/10356225.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值