SDNU 1269.整数序列(水题)

思路:最后忘了输出换行,导致我一直wa

Description

给你一个无规则的整数序列,选择号码的顺序如下:最大的,最小的,然后是第二大,第二小...直到所有的数都被选出来。例如:给你1 3 2 5 4,你应该输出5 1 4 2 3。

Input

有多个测试案例,每个案例始于一个整数N(1 <= N <= 100000),下面跟着N个整数

Output

按照题目描述输出序列

Sample Input

5
1 3 2 5 4

Sample Output

5 1 4 2 3

Source

#include <cstdio>
#include <iostream>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
using namespace std;
#define ll long long
const int maxn = 5100;

int n, a[100000+8], b[100000+8];

int main()
{
    while(~scanf("%d", &n) && n)
    {
        for(int i = 0; i<n; i++)
            scanf("%d", &a[i]);
        sort(a, a+n, greater<int>());
        int maxx = n-1, minn = 0;
        for(int i = 0; i<n; i++)
        {
            if(i%2 == 0)
            {
                b[i] = a[minn];
                minn++;
            }
            else
            {
                b[i] = a[maxx];
                maxx--;
            }
        }
        for(int i = 0; i<n; i++)
        {
            if(i)printf(" ");
            printf("%d", b[i]);
        }
        printf("\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/RootVount/p/10993259.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值