hdu 6045 Is Derek lying?(思维推导)

Problem Description

Derek and Alfia are good friends.Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia.Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X,your total score is Y.”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.

Input

The first line consists of an integer T,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the meaning is mentioned above.

The second line consists of N characters,each character is “A” “B” or “C”,which represents the answer of Derek for each question.

The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

Output

For each test case,the output will be only a line.

Please print “Lying” if you can make sure that Derek is lying,otherwise please print “Not lying”.

Sample

Sample Input

2 
3 1 3 
AAA 
ABC 
5 5 0 
ABCBC 
ACBCB

Sample Output

Not lying 
Lying

题意:

  现在两个人同时回答一套题,ABC三个选项,只有一个是正确的,答对得一分,答错不得分,给出两个人的成绩和答案,判断这两个成绩是否合理。

  比如一共五个题,两个人的得分都是五分,然后两个人的答案都不相同,那么表示不合理。

思路:

  没什么技巧,就是推理题目。推理方法有很多种,只要合理就行。

  思路一:记录两个人答案相同的个数,如果  两个人成绩的和小于等于题目总数加上相同的个数  并且  两个人的分数差小于等于题目总数减去相同的个数,则表示没说谎。

  思路二:记录两人答案相同和不同的题数,如果  两个人成绩的和小于等于不同的个数加上两倍的相同的个数  并且   两个人分数差小于等于不相同的答案数,则表示没说谎

代码一:

/*
ACACBCA
BABACBB
*/
#include<stdio.h>
#include<math.h>
#include<cmath>
using namespace std;
char a1[80050],a2[80050];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,x,y,i,j;
        int butong=0,xiangtong=0;
        scanf("%d%d%d",&n,&x,&y);
        scanf("%s%s",a1,a2);
        for(i=0;i<n;i++)//计算相同和不同的个数
        {
            if(a1[i]==a2[i])
                xiangtong++;
            else
                butong++;
        }
        if(x+y<=n+xiangtong&&abs(x-y)<=n-xiangtong)
            printf("Not lying\n");
        else
            printf("Lying\n");
    }
}

代码二:

/*
ACACBCA
BABACBB
*/
#include<stdio.h>
#include<math.h>
#include<cmath>
using namespace std;
char a1[80050],a2[80050];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,x,y,i,j;
        int butong=0,xiangtong=0;
        scanf("%d%d%d",&n,&x,&y);
        scanf("%s%s",a1,a2);
        for(i=0;i<n;i++)//计算相同和不同的个数
        {
            if(a1[i]==a2[i])
                xiangtong++;
            else
                butong++;
        }
        if(abs(x-y)<=butong&&x+y<=butong+2*xiangtong)
            printf("Not lying\n");
        else
            printf("Lying\n");
    }
}

转载于:https://www.cnblogs.com/aiguona/p/7260331.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值