Is Derek lying?(HDU 6045)

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 103    Accepted Submission(s): 64


Problem Description
Derek  and  Alfia  are good friends. Derek  is Chinese,and  Alfia  is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of  N  choice questions and each question is followed by three choices marked “ A ” “ B ” and “ C ”.Each question has only one correct answer and each question is worth  1  point.It means that if your answer for this question is right,you can get  1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell  Derek  the total score of him and  Alfia .Then  Alfia will ask  Derek  the total score of her and he will tell her: “My total score is  X ,your total score is  Y .”But  Derek  is naughty,sometimes he may lie to her. Here give you the answer that  Derek  and  Alfia  made,you should judge whether  Derek  is lying.If there exists a set of standard answer satisfy the total score that  Derek  said,you can consider he is not lying,otherwise he is lying.
 

Input
The first line consists of an integer  T ,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers  N , X , Y ,the meaning is mentioned above.

The second line consists of  N  characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of  Derek  for each question.

The third line consists of  N  characters,the same form as the second line,which represents the answer of  Alfia  for each question.

Data Range: 1N80000 , 0X,YN, Ti=1N300000
 

Output
For each test case,the output will be only a line.

Please print “ Lying ” if you can make sure that  Derek  is lying,otherwise please print “ Not lying ”.
 

Sample Input
  
  
2 3 1 3 AAA ABC 5 5 0 ABCBC ACBCB
 

Sample Output
  
  
Not lying Lying


//***题意***:一开始输入n ,A, B,分别表示有n道题目,Derek对了道,Alfia对了B道,这A B是Derek瞎说的,可能是对的,也可能是Derek在撒谎,接下来2行,每行n个字母,分别表示2个人每人每题选了什么,这个是事实,正确的,每道题有3个选项(ABC),每题有且仅有一个正确答案。要让你判断Derek有没有撒谎。

//***思路***:设2个人正确的题数相减的绝对值为X,那么2个人至少要有X题的答案是不一样的,不然就是在撒谎。设2个人正确的题数相加的绝对值为Y,从第一题开始判断,先尽量使他们2个都对(如果2个人答案一样,判他们两个这题都是对的,2个人答案不一样,判一个对,一个错,谁对谁错无所谓,算他们2个对的总题数就行),如果达到了Y,证明没说谎,因为可以判他们之后的题都是错的(总共有3个选项,两个人最多选2个,让没选的那个为正确答案即可),若达不到Y,就说明在说谎,因为尽量使他们都对都打不到要求。


#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAX = 80000 + 100;

int n, x, y;
char str1[MAX];
char str2[MAX];

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d%d", &n, &x, &y);
		scanf("%s", str1);
		scanf("%s", str2);
		int ans = 0;
		int jia, jian;
		int sum = 0;

		jia = x + y;
		jian = abs(x - y);

		for (int i = 0; i < n; i++)
		{
			if (str1[i] != str2[i])
			{
				ans++;
				if (ans == jian)
					break;
			}
		}

		if (ans < jian)
		{
			printf("Lying\n");
			continue;
		}

		for (int i = 0; i < n; i++)
		{
			if (str1[i] == str2[i])
				sum += 2;
			if (str1[i] != str2[i])
				sum++;
			if (sum == jia)
				break;
		}

		if (sum < jia)
		{
			printf("Lying\n");
			continue;
		}
		else
			printf("Not lying\n");
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值