hdu 1020 Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43496    Accepted Submission(s): 19218


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
 
  
2 ABC ABBCCC
 

Sample Output
 
  
ABC A2B3C
题意是说假如输入“AABBAA” 应输入2A2B2A(坑在这)
#include<iostream>
#include<string>
#include<math.h>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<map> 
using namespace std;
int main()
{
	int num,j,k,i;
	cin>>num;
	while(num--)
	{
		string s1;
		int sum=0,k=0;
		cin>>s1;
		sum=0;
		for(i=1;i<=s1.size();i++)
		{
		    if(s1[i]!=s1[i-1])
		    {   
		    	sum=i-k+1-1;
		    	if(sum==1)
		    	cout<<s1[i-1];
		    	else
		    	cout<<sum<<s1[i-1];
		    	k=i;	
			}
		}
		cout<<endl;
	  }	
   return 0;
} 


转载于:https://www.cnblogs.com/xunalove/p/6809288.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值