杭电 HDU 1020 Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29834    Accepted Submission(s): 13212


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
  
  
2 ABC ABBCCC
 

Sample Output
  
  
ABC A2B3C
 

Author
ZHANG Zheng
 
一个笔题 硬是他妈的让我wa次!错误原因是逻辑错误,如下错误代码:
虽然用一个数组记录下对应的字母出现次数;
但是输出的时候可是从他妈零依次检索,所以输出顺序完全就不同了但计数没问题;
#include<iostream>
#include<string>
using namespace std;

int main()
{
	string str;
	int  s[10003];
	int N;
	cin>>N;
	while(N--)
	{
		int ac=0;
		char ch;
		memset(s,0,sizeof(s));
		cin>>str;
		for(int i=0;i<str.size();i++)
		{
			ac=str[i]-65;
			s[ac]++;
		}
		for(int j=0;j<26;j++)
			if(s[j]==1)
			{
				ch=j+65;
				cout<<ch;
			}
			else if(s[j]!=1&&s[j])
			{
				ch=j+65;
				cout<<s[j]<<ch;
			}
			cout<<endl;
	}
	return 0;
}

改正后,重新编写,once AC!:

#include<iostream>
using namespace std;
#include<string>
 
int main()
{
	string str;

	int n,i;
	cin>>n;
	while(n--)
	{	
		int count =1;
		cin>>str;
		for(i=1;i<str.size();i++)
		{
			if(str[i]==str[i-1])
				count++;
			else
			{
				if(count==1)
					cout<<str[i-1];
				else
					cout<<count<<str[i-1];
				count=1;
			}
		}
		if(count>1)
			cout<<count<<str[i-1];
	cout<<endl;
	}
	return 0;
}




 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值