HDU 1020 Encoding(字符串合并)

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38631    Accepted Submission(s): 17109


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
  
  
2 ABC ABBCCC
 

Sample Output
  
  
ABC A2B3C
 

Author
ZHANG Zheng

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    int n,i,cnt;
    char str[10005];
    cin >> n;
    while(n--)
    {
        cin >> str;
        for(i = 0; str[i]!='\0';)
        {
            cnt = 1;
            while(str[i] == str[i+1])
            {
                cnt++;
                i++;
            }
            if(cnt == 1)
                cout << str[i];
            else
                cout << cnt << str[i];
            i++;
        }
        cout << endl;
    }
    return 0;
}

AC代码二(有点复杂)

#include <stdio.h>
#include <string.h>

int main()
{
    char a[10000];
    int n,i,length;
    int x;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        gets(a);
        length=strlen(a);
        x=1;
        for (i=0; i<length-1; i++)
        {
            if(a[i]==a[i+1])
            {
                x++;
                if (i==length-2)//最后两个字符相等
                {
                    printf("%d%c",x,a[length-1]);
                }
            }
            else
            {
                if (x!=1)
                    printf("%d",x);
                printf("%c",a[i]);

                if (i==length-2&&(a[length-1]!=a[length-2]))//最后两个字符不相等
                {
                    printf("%c",a[length-1]);
                }
                x=1;
            }
        }
        printf("\n");

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值