uva 10118 Free Candies

Problem Description

Little Bob is playing a game. He wants to win some candies in it - as
many as possible.

There are 4 piles, each pile contains N candies. Bob is given a basket
which can hold at most 5 candies. Each time, he puts a candy at the
top of one pile into the basket, and if there’re two candies of the
same color in it ,he can take both of them outside the basket and put
them into his own pocket. When the basket is full and there are no two
candies of the same color, the game ends. If the game is played
perfectly, the game will end with no candies left in the piles.
The Input
The input will contain no more than 10 test cases. Each test case
begins with a line containing a single integer n(1<=n<=40)
representing the height of the piles. In the following n lines, each
line contains four integers xi1,xi2,xi3,xi4 (in the range 1..20). Each
integer indicates the color of the corresponding candy. The test case
containing n=0 will terminate the input, you should not give an answer
to this case.
The Output
Output the number of pairs of candies that the cleverest
little child can take home. Print your answer in a single line for
each test case.
Sample Input
5
1 2 3 4
1 5 6 7
2 3 3 3
4 9 8 6
8 7 2 1
1
1 2 3 4
3
1 2 3 4
5 6 7 8
1 2 3 4
0
Sample Output
8
0
3

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

const int maxn = 50;
int n;
int f[maxn][maxn][maxn][maxn];
int piles[maxn][maxn];

int dp(int* r,int s,int* t)
{
    if(s==5) return f[t[0]][t[1]][t[2]][t[3]]=0;
    if(f[t[0]][t[1]][t[2]][t[3]] >= 0)return f[t[0]][t[1]][t[2]][t[3]];
    f[t[0]][t[1]][t[2]][t[3]] = 0;
    for(int i = 0; i < 4 ; i++ )
    {
        if(t[i]==n)continue;
        if(r[piles[i][t[i]]]==1)
        {
            int &v = f[t[0]][t[1]][t[2]][t[3]];
            r[piles[i][t[i]]]=0;
            t[i]++;
            v = max(v,dp(r,s-1,t) + 1);
            t[i]--;
            r[piles[i][t[i]]]=1;
        }
        else
        {
            int& v = f[t[0]][t[1]][t[2]][t[3]]; 
            r[piles[i][t[i]]]=1;
            t[i]++;
            v = max(v,dp(r,s+1,t));
            t[i]--;
            r[piles[i][t[i]]]=0;
        }
    }
    return f[t[0]][t[1]][t[2]][t[3]];
}

int main()
{
    while((cin >> n)&&n)
    {
        memset(f,-1,sizeof(f));
        for(int i = 0 ; i < n ; i++ )
            for(int j = 0 ; j < 4 ; j++ )
                cin >> piles[j][i];
        int r[25],top[4]={0,0,0,0};
        memset(r,0,sizeof(r));
        int ans = dp(r,0,top);
        cout << ans << endl;
    }
    return 0;
 } 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值