LA 3644 易爆物(并查集)

Problem Description:

A secret service developed a new kind of explosive that attain its
volatile property only when a specific association of products occurs.
Each product is a mix of two different simple compounds, to which we
call a binding pair. If N > 2, then mixing N different binding pairs
containing N simple compounds creates a powerful explosive. For
example, the binding pairs A+B, B+C, A+C (three pairs, three
compounds) result in an explosive, while A+B, B+C, A+D (three pairs,
four compounds) does not. You are not a secret agent but only a guy in
a delivery agency with one dangerous problem: receive binding pairs in
sequential order and place them in a cargo ship. However, you must
avoid placing in the same room an explosive association. So, after
placing a set of pairs, if you receive one pair that might produce an
explosion with some of the pairs already in stock, you must refuse it,
otherwise, you must accept it. An example. Lets assume you receive the
following sequence: A+B, G+B, D+F, A+E, E+G, F+H. You would accept the
first four pairs but then refuse E+G since it would be possible to
make the following explosive with the previous pairs: A+B, G+B, A+E,
E+G (4 pairs with 4 simple compounds). Finally, you would accept the
last pair, F+H. Compute the number of refusals given a sequence of
binding pairs.
Input The input will contain several test cases, each of them as described below. Consecutive test cases are separated by a single
blank line. Instead of letters we will use integers to represent
compounds. The input contains several lines. Each line (except the
last) consists of two integers (each integer lies between 0 and 105 )
separated by a single space, representing a binding pair. Each test
case ends in a line with the number ‘-1’. You may assume that no
repeated binding pairs appears in the input.
Output For each test case, the output must follow the description below. A single line with the number of refusals.
Sample Input
1 2
3 4
3 5
3 1
2 3
4 1
2 6
6 5
-1
Sample Output
3

#include<iostream>
using namespace std;

int p[100010];
int find(int xx){return p[xx]==xx?xx:p[xx]=find(p[xx]);}

int main()
{
    int x,y;
    while(cin >> x)
    {
        for(int i = 0;i <= 100000;i++)p[i]=i;
        int ans = 0;
        while(x!=-1)
        {
            cin >> y;
            int xx = find(x);
            int yy = find(y);
            if(xx==yy)ans++;
            else p[yy]=xx;
            cin >> x;
        }
        cout << ans << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值