XTU 1236 Fraction

Fraction

 
Accepted : 173 Submit : 1084
Time Limit : 1000 MS Memory Limit : 65536 KB

Fraction

Problem Description:

Everyone has silly periods, especially for RenShengGe. It's a sunny day, no one knows what happened to RenShengGe, RenShengGe says that he wants to change all decimal fractions between 0 and 1 to fraction. In addtion, he says decimal fractions are too complicate, and set that \\(1 \\over 3\\) is much more convient than 0.33333... as an example to support his theory.

So, RenShengGe lists a lot of numbers in textbooks and starts his great work. To his dissapoint, he soon realizes that the denominator of the fraction may be very big which kills the simplicity that support of his theory.

But RenShengGe is famous for his persistence, so he decided to sacrifice some accuracy of fractions. Ok, In his new solution, he confines the denominator in [1,1000] and figure out the least absolute different fractions with the decimal fraction under his restriction. If several fractions satifies the restriction, he chooses the smallest one with simplest formation.

Input

The first line contains a number T(no more than 10000) which represents the number of test cases.

And there followed T lines, each line contains a finite decimal fraction x that satisfies \\(x \\in (0,1)\\).

Output

For each test case, transform x in RenShengGe's rule.

Sample Input

3
0.9999999999999
0.3333333333333
0.2222222222222

Sample Output

1/1
1/3
2/9


解题思路:直接暴力枚举分母即可,从1~1000,题目也提示了输入用double

代码如下:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f
#define maxn 200005
using namespace std;
int gcd(int a,int b)///求最大公约数
{
    return !b ? a : gcd(b,a%b);
}
int main()
{
    int T;
    double n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf",&n);
        int x,y,t;
        double minn=100.0,num;
        for(int i=1; i<=1000; i++)
        {
            t=int(n*i+0.5);
            num=fabs(((double)t)/i-n);
            if(num<minn)
            {
                x=t,y=i;
                minn=num;
            }
        }
        int f=gcd(x,y);
        printf("%d/%d\n",x/f,y/f);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值