1115:最短的名字
Time Limit: 5 Sec
Memory Limit: 64 Mb
Submitted: 1518
Solved: 584
Description
在一个奇怪的村子中,很多人的名字都很长,比如aaaaa, bbb and abababab。
名字这么长,叫全名显然起来很不方便。所以村民之间一般只叫名字的前缀。比如叫'aaaaa'的时候可以只叫'aaa',因为没有第二个人名字的前三个字母是'aaa'。不过你不能叫'a',因为有两个人的名字都以'a'开头。村里的人都很聪明,他们总是用最短的称呼叫人。输入保证村里不会有一个人的名字是另外一个人名字的前缀(作为推论,任意两个人的名字都不会相同)。
如果村里的某个人要叫所有人的名字(包括他自己),他一共会说多少个字母?
Input
输入第一行为数据组数T (T<=10)。每组数据第一行为一个整数n(1<=n<=1000),即村里的人数。以下n行每行为一个人的名字(仅有小写字母组成)。输入保证一个村里所有人名字的长度之和不超过1,000,000。
Output
对于每组数据,输出所有人名字的字母总数。
Sample Input
1 3 aaaaa bbb abababab
Sample Output
5
解题思路:这个题目就是一个字典树的简单应用,为了做这个题,看了好久的字典树知识,还看了别人的代码,解题思路才做出来,自己掌握了方法,以后再也不用担心了。。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <iostream>
#include <vector>
using namespace std;
char s[1000005];
typedef struct node{///创建节点的结构体
int k;
struct node *next[26];///储存的数组,大小可随题目改变
}node;
node * newnode()///创建一个新的节点
{
node *z;
z=(node*)malloc(sizeof(node));
z->k=1;
for(int i=0;i<26;i++)
z->next[i]=NULL;
return z;
}
void bulid_tree(node *tree,char *s)///建树
{
node *t;
t=tree;
int l=strlen(s),g;
for(int i=0;i<l;i++)
{
g=s[i]-'a';
if(t->next[g]==NULL)
{
t->next[g]=newnode();
t=t->next[g];
}
else
{
t=t->next[g];
t->k++;
}
}
}
int search_tree(node *tree)///对字典树进行查询
{
node *t;
int sum=0;
t=tree;
for(int i=0;i<26;i++)
{
if(tree->next[i]!=NULL)
{
t=tree->next[i];
sum+=t->k;
if(t->k>1)
sum+=search_tree(t);
}
}
return sum;
}
void release_tree(node *tree)///内存的释放
{
for(int i=0;i<26;i++)
if(tree->next[i]!=NULL)
release_tree(tree->next[i]);
free(tree);///释放内存的函数
}
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
node *tree;
tree=(node*)malloc(sizeof(node));
tree->k=0;
for(int i=0;i<26;i++)
tree->next[i]=NULL;
for(int i=0;i<n;i++)
{
cin>>s;
bulid_tree(tree,s);
}
printf("%d\n",search_tree(tree));
release_tree(tree);
}
return 0;
}