HDU 1754

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32300    Accepted Submission(s): 12787

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 
Output
对于每一次询问操作,在一行里面输出最高成绩。
 
Sample Input
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 
Sample Output
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin
 这是用结构体写的,用指针或直接数组也可以。
#include<stdio.h>
#include<iostream>
using namespace std;
#define N 200005
int val[N];
struct node
{
    int max;
    int left;
    int right;
} tree[4*N];
int max(int x,int y)
{
    return x>y?x:y;
}
//建立线段树
int create(int root,int left,int right)
{
    // 当前节点所表示的区间
    tree[root].left=left;
    tree[root].right=right;
     // 如果左右区间相同,说明此节点为叶子,max应储存对应某个学生的成绩
     //   printf("(%d,%d)  root=%d\n",left,right,root);
    if(left == right)
        return tree[root].max=val[left];
    // 递归建立左右子树,并从子树中获得最大值
    int a,b,middle=(left+right)/2;
    a=create(2*root,left,middle);
    b=create(2*root+1,middle+1,right);
    return tree[root].max=max(a,b);
}
// 从节点 root 开始,查找 left 和 right 之间的最大值
int calculate(int root,int left,int right)
{
    // 若此区间与 root 所管理的区间无交集
    if(tree[root].left>right || tree[root].right<left)
        return 0;
    // 若此区间包含root 所管理的区间
    if(tree[root].left>=left && tree[root].right<=right)
        return tree[root].max;
    // 若此区间与 root 所管理的区间部分相交
    int a,b;
    a=calculate(2*root,left,right);
    b=calculate(2*root+1,left,right);
    return max(a,b);
}
// 修改 pos 点的值
int update(int root,int pos,int val)
{
     // 若 pos超出了root 所管理的区间内
    if(pos<tree[root].left || pos>tree[root].right)
        return tree[root].max;
    // 如果root正好是一个符合条件的叶子
    if(tree[root].left==pos && tree[root].right==pos)
        return tree[root].max=val;
    int a,b;
    a=update(2*root,pos,val);
    b=update(2*root+1,pos,val);
    return tree[root].max=max(a,b);
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1; i<=n; i++)
           scanf("%d",&val[i]);
        create(1,1,n);
        
        for(int i=0; i<m; i++)
        {
            char op;
            int a,b;
            scanf("\n%c%d%d",&op,&a,&b);
            if(op=='Q')
                printf("%d\n",calculate(1,a,b));
            else
                update(1,a,b);
        }
        
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/man1304010109/p/3607735.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值