HDU -> acm -> Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
 
 
1 1 3
1 2 10
0 0 0
Sample Output
2
5

当第一眼看到这个题目时,首先想到的是用数组解决,把数组尽量开大,然后通过数组前两个数推出的后一个,重复操作云云。


但转念一想,这题貌似递归也能解,正好前段时间学了一下递归,及时练习巩固下还是挺重要的,然后……
#include <stdio.h>
#include <stdlib.h>
int number_sequence(int a, int b, int n)
{
    if(n == 1 || n == 2)
        return 1;
    return((a * number_sequence(a, b, n-1) + b * number_sequence(a, b, n - 2)) % 7);
}
int main()
{
    int a, b ,n;
    while(scanf("%d %d %d", &a, &b, &n) != EOF && a != 0 && b != 0 && n != 0)
    {
        printf("%d\n", number_sequence(a, b, n));
    }
    return 0;
}

Memory Limit Exceeded
。。。
。。。
。。。

很难受,试了几次都说内存超过限度,最后在大神的博客里找到解决方法 点击打开链接
简单概括一下问题所在:

由于n的值的不确定性导致调用递归的次数可能变得很长,那么就会占用大量内存,出现 Memory Limit Exceeded
的情况;通过观察可以得知,每一次调用函数得到的返回值是0~6中的一个数,那么f(n-1),f(n-2)各有7
种情况,f(n)又由f(n-1)与f(n-2)决定,那么f(n)的值必定是有规律的,且最大的一个循环长度是7 * 7 = 49
种,故只要将 printf("%d\n", number_sequence(a, b, n))中输入的n,替换成n / 49即可
#include <stdio.h>
#include <stdlib.h>
int number_sequence(int a, int b, int n)
{
    if(n == 1 || n == 2)
        return 1;
    return((a * number_sequence(a, b, n-1) + b * number_sequence(a, b, n - 2)) % 7);
}
int main()
{
    int a, b ,n;
    while(scanf("%d %d %d", &a, &b, &n) != EOF && a != 0 && b != 0 && n != 0)
    {
        printf("%d\n", number_sequence(a, b, n / 49));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值