hdu-1083-Courses

题目衔接:http://acm.hdu.edu.cn/showproblem.php?pid=1083

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10314    Accepted Submission(s): 4877


 

Problem Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

 

 

Sample Input

 

2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1

 

 

Sample Output

 

YES NO

 

 

Source

Southeastern Europe 2000

 题目大意:一共有N个学生跟P门课程,一个学生可以任意选一门或多门课,问是否达成:

  1.每个学生选的都是不同的课(即不能有两个学生选同一门课)

  2.每门课都有一个代表(即P门课都被成功选过)

思路:二分匹配,只要看懂了题意就不难,注意他的输入为:p行然后第一门先输入对这门功课感兴趣的学生总人数,然后是那几个学生,例如样例:表示课程1有3人感兴趣分别是学生1,学生2,学生3,然后敲个板子,最后判断能不能相等就可以了

代码:

#include<map>
#include<stack>
#include<cmath>
#include<queue>
#include<vector>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 1100
#define ll long long
#define inf 9999999
int p,n;
int e[maxn][maxn];
int book[maxn];
int match[maxn];
int dfs(int u)
{
    int i,j;
    for(i=1; i<=n; i++)
    {
        if(!book[i]&&e[u][i]==1)
        {
            book[i]=1;
            if(match[i]==0||dfs(match[i]))
            {
                match[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int test;
    scanf("%d",&test);
    while(test--)
    {
        int i,j,k,t1,t2,ans=0;
        scanf("%d%d",&p,&n);
        memset(book,0,sizeof(book));
        memset(match,0,sizeof(match));
        memset(e,0,sizeof(e));
        for(i=1; i<=p; i++)
        {
            scanf("%d",&t1);
            while(t1--)
            {
                scanf("%d",&t2);
                e[i][t2]=1;
            }
        }
        for(i=1; i<=p; i++)
        {
            memset(book,0,sizeof(book));
            if(dfs(i))
            {
                ans++;
            }
        }
        if(ans==p)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值