hdoj1028 Ignatius and the Princess III(整数分解)


Ignatius and the Princess III

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
并未找出递推式,然后做法有点傻 委屈,数据太大,单纯递归肯定TLE;先用递归打印出前120项(需要运行大约6分钟 大哭orz,递归效率低,等的心好累),复制下来再直接打表。。。。。。。。。。
代码:
#include<stdio.h>
int k,z;
void f(int n,int m)
{
    if(n==0||m==1){
        k++;
        z=0;return ;

    }
    int i;
    for(i=z;i<=n/m;i++){
        z=i;
        f(n-i,m-1);
    }

}

int main()
{
    int n;
    int s[130]={0,1,2,3,5,7,11,15,22,30,42,56,77,101,135,176,231,297,385,490,627,792,1002,
    1255,1575,1958,2436,3010,3718,4565,5604,6842,8349,10143,12310,14883,17977,21637,26015,
    31185,37338,44583,53174,63261,75175,89134,105558,124754,147273,173525,
    204226,239943,281589,329931,386155,451276,526823,614154,715220,831820,966467,
    1121505,1300156,1505499,1741630,2012558,2323520,2679689,3087735,3554345
,4087968,4697205,5392783,6185689,7089500,8118264,9289091,10619863,12132164
,13848650,15796476,18004327,20506255,23338469,26543660,30167357,34262962,
38887673,44108109,49995925,56634173,64112359,72533807,82010177,92669720,104651419
,118114304,133230930,150198136,169229875,190569292,214481126,241265379,
271248950,304801365,342325709,384276336,431149389,483502844,541946240,607163746,
679903203,761002156,851376628,952050665,1064144451,1188908248,1327710076,1482074143,1653668665,1844349560};
    int i;
    for(i=1;i<=10;i++)
    {
        k=0;f(i,i);

    }

    while(scanf("%d",&n)!=EOF)
    {
        k=0;z=0;

        printf("%d\n",s[n]);


    }




    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值