hdu 5813 Elegant Construction (模式)

Elegant Construction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 27    Accepted Submission(s): 14
Special Judge


Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it's your showtime!
 

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
 

Output
For each test case, output "Case #X: Y" in a line (without quotes), where X is the case number starting from 1, and Y is "Yes" if you can construct successfully or "No" if it's impossible to reach the requirements.

If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
 

Sample Input
  
  
3 3 2 1 0 2 1 1 4 3 1 1 0
 

Sample Output
  
  
Case #1: Yes 2 1 2 2 3 Case #2: No Case #3: Yes 4 1 2 1 3 2 4 3 4


题意:一个有向图中,给你每个点能到达的其他点的个数,问这样的图是否存在,若存在则输出其中任意一种。



感悟:对于这种special judge的题目,如果思路正确,最后输出答案一定也是一样的。换句话说,虽然是special judge 但是当你建立出一种策略:

           比如这题的策略是:对于可达到的点相同的两个点X,Y而言,他们所连的点应该都是相同的。这样导致的结果就是当一个点来连接X后,它再连接Y点对它而言所能到达的点的个数只会加一(只多了Y这个点);

          这样对于每个点 i,只要连接与它最近且小于它的点 j (从可达点的个数考虑),然后再连接其他小于它的点k,这个时候每个k点对i的贡献只有1,因为k<=j,而根据上文定义, k所能到的除了k j都能到,对i而言,小于它的点只会被分为j能到达的和j不能到达但是与j所能到达的某个点连接的或者是独立的点。所以这样递推下去就能得到答案。

         为了保证先处理可达数小的点,要先排序。

当你选取出这样的一种策略时,问题就迎刃而解了。

           

代码:

#include <bits/stdc++.h>

using namespace std;

const int N=1005;
typedef struct node
{
    int x,id;
    bool operator < (const node &other) const
    {
        return x<other.x;
    }
}node;
node num[N];
stack<int>st;
vector<int>ve[N];
int main()
{
    int n,t,flag;
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        while(!st.empty())
            st.pop();
        scanf("%d",&n);
        flag=1;
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&num[j].x);
            num[j].id=j;
            ve[j].clear();
        }
        sort(num+1,num+n+1);
        printf("Case #%d: ",i);
        int preid=0,prev=0;
        for(int j=1;j<=n&&flag;j++)
        {
            int id=num[j].id;
            if(num[j].x>prev)
            {
                int k,len=num[j].x;
                len-=prev;
                for(k=0;k<len&&!st.empty();k++)
                {
                    int c=st.top();
                    ve[id].push_back(c);
                    st.pop();
                }
                if(k<len)
                {
                    flag=0;
                }
                preid=id;
            }
            if(num[j].x==prev)
            {
                ve[id]=ve[preid];
            }
            st.push(id);
            prev=num[j].x;
        }
        if(!flag)
        {
            puts("No");
        }
        else
        {
            puts("Yes");
            int ans=0;
            for(int j=1;j<=n;j++)
                ans+=ve[j].size();
            cout<<ans<<endl;
            for(int j=1;j<=n;j++)
            {
                for(int k=0;k<ve[j].size();k++)
                printf("%d %d\n",j,ve[j][k]);
            }
        }
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值