hdu 5813 Elegant Construction (构造)

Elegant Construction

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 104 Accepted Submission(s): 53
Special Judge

Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it’s your showtime!

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.

Output
For each test case, output “Case #X: Y” in a line (without quotes), where X is the case number starting from 1, and Y is “Yes” if you can construct successfully or “No” if it’s impossible to reach the requirements.

If Y is “Yes”, output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.

Sample Input

3
3
2 1 0
2
1 1
4
3 1 1 0

Sample Output

Case #1: Yes
2
1 2
2 3
Case #2: No
Case #3: Yes
4
1 2
1 3
2 4
3 4

题意:给你 n <script id="MathJax-Element-103" type="math/tex">n</script>个点,然后给你每个点可以到达的点的个数,让你构造一个满足条件的无环有向图。

思路:我们将每个点按照能达到的个数从小到大排序,然后一个一个扫,因为点数少的点必定是在最底层,所以说我们每次寻找和当前点相连的点都向下找,如果有不能找到的点就说明不能构成满足条件的图,否则继续。

ac代码:

/* ***********************************************
Author       : AnICoo1
Created Time : 2016-08-09-13.17 Tuesday
File Name    : D:\MyCode\2016-8月\2016-8-9.cpp
LANGUAGE     : C++
Copyright  2016 clh All Rights Reserved
************************************************ */
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<map>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x,y) memset(x,(y),sizeof(x))
#define PI acos(-1)
#define eps 1e-8
using namespace std;
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
ll powmod(ll a,ll b,ll MOD){ll ans=1;while(b){if(b%2)ans=ans*a%MOD;a=a*a%MOD;b/=2;}return ans;}
double dpow(double a,ll b){double ans=1.0;while(b){if(b%2)ans=ans*a;a=a*a;b/=2;}return ans;}
//head
struct s
{
    int id;
    int num;
}p[MAXN];
int vis[MAXN];
struct Edge
{
    int from,to,val,next;
}edge[MAXN];
int v[1010];
int head[MAXN],edgenum;
void Add(int u,int v,int w)
{
    Edge E={u,v,w,head[u]};
    edge[edgenum]=E;
    head[u]=edgenum++;
}
bool cmp(s A,s B)
{
    return A.num<B.num;
}
int main()
{
    int t,cas=1;scanf("%d",&t);
    while(t--)
    {
        int n;scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&p[i].num);
            p[i].id=i;
        }
        printf("Case #%d: ",cas++);
        sort(p+1,p+n+1,cmp);
        if(p[1].num)
        {
            printf("No\n");
            continue;
        }
        mem(head,-1);edgenum=0;int cnt=0;int flag=0;
        for(int i=1;i<=n;i++)
        {
            if(p[i].num==0) continue;
            int k=p[i].num;
            for(int j=1;k>0&&j<i;j++)
            {
                if(p[i].num<p[j].num) continue;
                Add(p[i].id,p[j].id,1);
                cnt++;
                k--;
            }
            if(k>0)
            {
                flag=1;
                break;
            }
        }
        if(flag)
        {
            printf("No\n");
            continue;
        }
        printf("Yes\n%d\n",cnt);
        for(int i=1;i<=n;i++)
        {
            for(int j=head[i];j!=-1;j=edge[j].next)
            printf("%d %d\n",i,edge[j].to);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值