HDU1206 Ignatius and the Princess I(BFS+优先队列)

9 篇文章 0 订阅

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166’s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166’s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output
For each test case, you should output “God please help our poor hero.” if Ignatius can’t reach the target position, or you should output “It takes n seconds to reach the target position, let me show you the way.”(n is the minimum seconds), and tell our hero the whole path. Output a line contains “FINISH” after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input
5 6
.XX.1.
…X.2.
2…X.
…XX.
XXXXX.
5 6
.XX.1.
…X.2.
2…X.
…XX.
XXXXX1
5 6
.XX…
…XX1.
2…X.
…XX.
XXXXX.

Sample Output
It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH

题目大意:给定一个n*m的地图:

  • 起点为(0,0),终点为(n-1,m-1)。
  • '.'表示可走的路,可从临近位置花1s走到这里;
  • 'X’表示有障碍物,不能走到这里;
  • ’n’表示这里有一只怪物,其血量为n,可从临近位置花1s走到这里,并在此停留ns。

现在要求是否有起点到终点的最短路径并输出最短路径。

os:

  1. 最开始做的时候不知道有怪物的BFS最短路径怎么处理,查了之后才明白用优先队列。。。
  2. 从起点开始往终点BFS的话,到时候输出路径要用到递归。所以可以反其道而行之,从终点开始往起点BFS,就可以用迭代输出路径了。

思路:

  1. 用e[ ][ ]存图:-1表示‘X’、0表示‘.’、数字n表示’n’,pre[ ][ ]存每个结点的前驱结点。
  2. 在输入的时候对字符做相应处理,并存放到e[ ][ ]中。
  3. BFS的时候用优先队列,注意重载<即可。

代码如下:

#include <iostream>
#include <cstdio>
#include <queue>
#define maxn 105
using namespace std;
typedef pair<int, int>P;
struct node
{
    int x, y, step;
    node(int tx, int ty, int tstep):x(tx), y(ty), step(tstep){}
    bool operator < (const node &point)const{return point.step < step;}
};
int n, m;
int e[maxn][maxn];
P pre[maxn][maxn];/* <first, second> : <x, y> */
void bfs(int stx, int sty)
{
    priority_queue<node>q;
    int book[maxn][maxn] = {0};
    int next[4][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}};

    book[stx][sty] = 1;
    pre[stx][sty] = P(-1, -1);
    q.push(node(stx, sty, e[stx][sty]));
    while(!q.empty())
    {
        node head = q.top();
        q.pop();
        if(head.x == 0 && head.y == 0)/* 到了终点 */
        {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n", head.step);
            int step = 1;/* 记录秒 */ 
            int x = head.x;
            int y = head.y;
            int prex = pre[x][y].first;
            int prey = pre[x][y].second;
            while(pre[x][y].first != -1)
            {
                printf("%ds:(%d,%d)->(%d,%d)\n",step++, x, y, prex, prey);
                while(e[prex][prey]--)
                {
                     printf("%ds:FIGHT AT (%d,%d)\n",step++, prex, prey);
                }
                x = prex;
                y = prey;
                prex = pre[x][y].first;
                prey = pre[x][y].second;
            }
            printf("FINISH\n");
            return ;
        }
        int k;
        for(k=0; k<4; k++)
        {
            int tx = head.x + next[k][0];
            int ty = head.y + next[k][1];
            if(tx < 0 || tx > n-1 || ty < 0 || ty > m-1) continue;/* 越界 */
            if(book[tx][ty] || e[tx][ty] == -1) continue;/* 已走过或不能走 */
            book[tx][ty] = 1;
            pre[tx][ty] = P(head.x, head.y);
            q.push(node(tx, ty, head.step+1+e[tx][ty]));
        }
    }
    printf("God please help our poor hero.\n");
    printf("FINISH\n");
    return;
}
int main()
{
    while(scanf("%d%d", &n, &m) != EOF)
    {
        getchar();
        int i, j;
        for(i=0; i<n; i++)/* 在输入的时候就做相应的处理,方便后续的操作 */
        {
            for(j=0; j<m; j++)
            {
                char c = getchar();
                if(c == 'X') e[i][j] = -1;/* 不能走 */
                else if(c == '.') e[i][j] = 0;/* 表示在此不用停留 */
                else e[i][j] = c - '0';/* 在此停留 (c-'0') s */
            }
            getchar();
        }
        bfs(n-1, m-1);/* 逆向思维:从终点开始bfs,便于迭代输出 */
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值