Team Contests - Warmup Problem C

Problem C

Problem Description

Definite an operation work (Q,x) as sequence Q from the first number on,keep the top x numbers and delete followed x numbers, keep the next x numbers and delete followed x numbers, then keep recycling this process.

Q is the positive integer sequence, Given a sequence A, operating Work(Q,Ai) upon positive integer sequence output the nth member after n operations.

Input

First line contains  T(T10) denoting the number of test cases.

  T cases follows. For each cases: 

  First line contains integer n(0<n10000), next line contains n integers Ai(0<Ai1000) indicates the i-th operation.

Output

For each case output the answer in one line.

Sample Input

2
3
1 2 3
3
3 2 1

Sample Output

9
15

从后往前推出公式,但是会爆longlong,用java写就好了。

import java.io.*;
import java.math.*;
import java.util.*;

public class Main {
    static int[] a; 
    public static void main(String args[]) {
        Scanner cin = new Scanner(System.in);
        int t = cin.nextInt();
        while(t-->0) {
            a = new int[10010];
            int n = cin.nextInt();
            for(int i = 1; i <= n; i++) a[i] = cin.nextInt();
            BigInteger ans = BigInteger.valueOf(n);
            for(int i = n; i >= 1; i--) {
                int tmp = 0;
                if(ans.mod(BigInteger.valueOf(a[i])).compareTo(BigInteger.ZERO) == 0) tmp = 1;
                BigInteger tmp2 = ans.divide(BigInteger.valueOf(a[i])).subtract(BigInteger.valueOf(tmp));
                ans = ans.add(tmp2.multiply(BigInteger.valueOf(a[i])));
            }
            System.out.println(ans);
        }
    }
}

 

转载于:https://www.cnblogs.com/lonewanderer/p/5677870.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值