POJ 2413 How many Fibs? (java大数)

How many Fibs?
 

Description

Recall the definition of the Fibonacci numbers: 
f1 := 1 

f2 := 2
fn := f
n-1
 + f
n-2
     (n>=3) 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a,b].

Input

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a=b=0. Otherwise, a<=b<=10 100. The numbers a and b are given with no superfluous leading zeros.

Output

For each test case output on a single line the number of Fibonacci numbers fi with a<=fi<=b.

Sample Input

10 100
1234567890 9876543210
0 0

Sample Output

5
4

网上的博弈题分类中出了一个叛徒...明明不是博弈。java顺手ac了。

import java.io.*;
import java.math.*;
import java.util.*;

public class Main {
    public static void main(String args[]) {
        BigInteger a, b;
        Scanner in = new Scanner(System.in);
        while(in.hasNext()) {
            a = in.nextBigInteger();
            b = in.nextBigInteger();
            if(a.equals(BigInteger.ZERO) && b.equals(BigInteger.ZERO)) break;
            int cnt = 0;
            BigInteger f[] = new BigInteger[5000];
            f[1] = BigInteger.valueOf(1); f[2] = BigInteger.valueOf(2);
            for(int i = 1; ; i++) {
                if(i >= 3)
                    f[i] = f[i - 1].add(f[i - 2]);
                if(f[i].compareTo(b) > 0) break;
                if(a.compareTo(f[i]) <= 0) {
                    cnt++;
                }
            }
            System.out.println(cnt);
        }
    }
}

 

转载于:https://www.cnblogs.com/lonewanderer/p/5690890.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值