How many Fibs?(java大数)

73 篇文章 0 订阅
27 篇文章 1 订阅

Link:http://poj.org/problem?id=2413

Problem:

How many Fibs?
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10628 Accepted: 3947

Description

Recall the definition of the Fibonacci numbers: 
f1 := 1 

f2 := 2 

fn := fn-1 + fn-2     (n>=3) 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a,b].

Input

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a=b=0. Otherwise, a<=b<=10 100. The numbers a and b are given with no superfluous leading zeros.

Output

For each test case output on a single line the number of Fibonacci numbers fi with a<=fi<=b.

Sample Input

10 100
1234567890 9876543210
0 0

Sample Output

5
4

Source

import java.util.*;
import java.io.*;
import java.math.*;
import java.text.*;


public class pes {
public static void main(String[] args)
{
BigInteger x,y,f1,f2,t;
BigInteger ans;
Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{
x=cin.nextBigInteger();
y=cin.nextBigInteger();
if(x.compareTo(BigInteger.valueOf(0))==0&&y.compareTo(BigInteger.ZERO)==0)
break;
ans=BigInteger.ZERO;
f1=BigInteger.ONE;
f2=BigInteger.valueOf(2);
while(f1.compareTo(x)<0)
{
t=f2;
f2=f2.add(f1);
f1=t;
}
while(f1.compareTo(y)<=0)
{
ans=ans.add(BigInteger.ONE);
t=f2;
f2=f2.add(f1);
f1=t;
}
System.out.println(ans);
}
}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值