hdu 5775 Bubble Sort (树状数组)

Bubble Sort

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 591    Accepted Submission(s): 359


Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
 

 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case. 
 

 

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.
 

 

Sample Input
2
3
3 1 2
3
1 2 3
 

 

Sample Output
Case #1: 1 1 2
Case #2: 0 0 0
Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3) the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3 In second case, the array has already in increasing order. So the answer of every number is 0.
 
题意是给出一个由1~n组成的序列,求出模拟冒泡排序时,每个数能到达的最左位置和最右位置的差。
暴力找下规律,会发现一个数右移的次数是右边比这个数小的数的个数,所以右边的位置是当前位置加上后面比这个数小的数的个数。左边位置是排完序后的位置与一开始所在的位置中更小的那个。求右边比这个数小的数的个数用树状数组,类似白书例题LA 4329的做法。
 
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 10;
int C[maxn];
int n;

inline int lowbit(int x) {
    return x & (-x);
}

int sum(int x) {
    int ret = 0;
    while(x > 0) {
        ret += C[x]; x -= lowbit(x);
    }
    return ret;
}

void add(int x, int d) {
    while(x <= maxn) {
        C[x] += d; x += lowbit(x);
    }
}

int a[maxn];
int r[maxn], l[maxn];
int id[maxn];

int main() {
    int t;
    scanf("%d", &t);
    int cas = 0;
    while(t--) {
        memset(C, 0, sizeof(C));
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) 
            scanf("%d", &a[i]);

        for(int i = n; i >= 1; i--) {
            add(a[i], 1);
            r[i] = sum(a[i] - 1);
            id[a[i]] = i;
        }

        //for(int i = 1; i <= n; i++) printf("%d ", r[i]); puts("");
        vector<int> ans;
        for(int i = 1; i <= n; i++) {
            int ll = min(id[i], i);
            int rr = id[i] + r[id[i]];
            //printf("check %d %d %d\n", i, ll, rr);
            ans.push_back(rr - ll);
        }
        printf("Case #%d:", ++cas);
        for(int i = 0; i < ans.size(); i++) {
            printf(" %d", ans[i]);
        }puts("");
    }
}

 

转载于:https://www.cnblogs.com/lonewanderer/p/5719457.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值