POJ3026

http://poj.org/problem?id=3026

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance.

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
#####
#A#A##
# # A#
#S ##
#####
7 7
#####
#AAA###
# A#
# S ###
# #
#AAA###
#####

Sample Output

8
11

本题大意(bfs+prim,自己也只有在研究了大佬的代码后才知道怎么做,有些大佬的代码看都看不懂,真是让人头大。)

一群外星人在一张地图当中,你有不小于外星人数量的人手,你要找到他们,并且你可以在找到外星人或出发时时将人手分成任意两部分(这是不是有些象是最小树的生成)。
抽象一下本题,有n(n<=100)个点,已知各点的坐标,求最小树的生成的距离。
因为这里有墙,所以查找个点之间的距离需要用到bfs搜索,将每一个外星人和起始点都搜索一次。

#include<iostream>
#include<cstring>
using namespace std;
const int inf=666666;
char map[55][55];
int node[55][55];      //记录能否通过该点 
int Case,col,row,num;  //测试样例个数,行,列 ,以及外星人和起点的总个数 
int dis[105][105];     //将每一个可以通过的点当成一个节点来做图 
int edge[105][105];    //将一百个外星人以及一个起点做出一张图(此图从dis中抽出)

struct mo{
	int row,col;
}move[4]={{1,0},{-1,0},{0,1},{0,-1}};

void inti(void)//void加不加无所谓,加了就是明确指出没有参数 
{
	memset(node,0,sizeof(node));
	num=0;
}

void bfs(int i,int j)
{
	int vis[55][55];
	int que_x[2505],que_y[2505];
	int st=0,ed=0;
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	vis[i][j]=1;
	que_x[ed]=i;
	que_y[ed++]=j;
	while(ed>st)
	{
		int x=que_x[st];
		int y=que_y[st++];
		if(node[x][y])
			edge[ node[i][j] ][ node[x][y] ]=dis[x][y];
		for(int i=0;i<4;i++)
		{
			int sx=x+move[i].row;
			int sy=y+move[i].col;
			if(!vis[sx][sy]&&sx<=row&&sx>=1&&sy>=1&&sy<=col&&map[sx][sy]!='#')
			{
				que_x[ed]=sx;
				que_y[ed++]=sy;
				vis[sx][sy]=1;
				dis[sx][sy]=dis[x][y]+1;
			}
		}
	}
}

int prim(void)
{
	int sum=1,ans=0;
	int MIN=inf,next=1,index;
	int dis_2[105],vis_2[105];
	memset(dis_2,inf,sizeof(dis_2));
	memset(vis_2,0,sizeof(vis_2));
	vis_2[next]=1;
	dis_2[next]=0;
	while(true)
	{
		if(sum>=num) break;
		MIN=inf;
		for(int i=2;i<=num;i++)
		{
			if(!vis_2[i]&&dis_2[i]>edge[next][i])
				dis_2[i]=edge[next][i];
			if(!vis_2[i]&&MIN>dis_2[i])
			{
				MIN=dis_2[i];
				index=i;
			}
		}
		vis_2[index]=1;
		ans+=MIN;
		next=index;
		sum++;
		//printf("%d\n",ans);
	}
	return ans;
}

int main()
{
	scanf("%d",&Case);
	while(Case--)
	{
		inti();
		scanf("%d%d",&col,&row);
		char temp[51];
		gets(temp);//这里贼坑,数据库里面的数据有点坑,在输入行和列后有空格
		for(int i=1;i<=row;i++)
		{
			gets(map[i]);
			for(int j=1;j<=col;j++)
			{
				if(map[i][j]=='S'||map[i][j]=='A')
					node[i][j]=++num;
			}
		}
		for(int i=1;i<=row;i++)
			for(int j=1;j<=col;j++)
				if(node[i][j])
					bfs(i,j);
		printf("%d\n",prim());
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值