UVA624——背包DP(回溯)——CD

Description

 

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

 


Assumptions:

  • number of tracks on the CD. does not exceed 20
  • no track is longer than N minutes
  • tracks do not repeat
  • length of each track is expressed as an integer number
  • N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

 

Input 

Any number of lines. Each one contains value  N, (after space) number of tracks and durations of the tracks. For example from first line in sample data:  N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

 

Output 

Set of tracks (and durations) which are the correct solutions and string ``  sum:" and sum of duration times.

 

Sample Input 

 

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2

 

Sample Output 

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45

 大意:最优解的回溯.要求输出最优解的各个阶段的值,用一个path[i][j]记录(PS:偶尔用个index结果是库定义~~~~编译错了四次....),因为输出是从前到后,一开始就要最优解,所以前面01背包的处理要反一下,每一次的得到最优解之后,j-=w[i]

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int dp[10005],w[25];
    int path[25][10005];
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        memset(dp,0,sizeof(dp));
        memset(w,0,sizeof(w));
        memset(path,0,sizeof(path));
        for(int i =1; i <= m ; i++)
            scanf("%d",&w[i]);
        for(int i = m; i >= 1 ;i--){
            for(int j = n; j >= w[i]; j--){
                if(dp[j] < dp[j-w[i]]+w[i]){
                    dp[j] = dp[j-w[i]]+w[i];
                    path[i][j] = 1;
                }
            }
         }
        for(int i = 1,j = n; i <= m ; i++){
            if(path[i][j]){
           printf("%d ",w[i]);
            j -= w[i];
            }
        }
       printf("sum:%d\n",dp[n]);
    }
   return 0;
} 
View Code

 

 
 

转载于:https://www.cnblogs.com/zero-begin/p/4445565.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值