HDU1024——DP——Max Sum Plus Plus

Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

 

Output
Output the maximal summation described above in one line.
 

 

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

 

Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

 

Author
JGShining(极光炫影)
 

 

Recommend
We have carefully selected several similar problems for you:   1074  1025  1081  1080  1160 
大意:主要是降低复杂度,问给你m个数要可以分成n块连续的数,问最大和是多少
定义dp[i][j]表示当前这个数为i,已经分了j块
可以转来的方向  1.块数不动多一个数   2.块数动了多一个数
动态转移方程  dp[i][j] = max(dp[i-1][j]+a[i],max(dp[1][j-1].....dp[i-1][j-1])+a[i]))
bing神代码好流弊。。定义一个数组记录前面一个块的前j-1中最大的值
那么最后答案就是这个max2(分成n组时1到j中最大的值
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1000010;
const int inf = 0x3f3f3f3f;
int dp[maxn];
int a[maxn],max1[maxn];
int main()
{
    int n,m;
    int max2;
    while(~scanf("%d%d",&n,&m)){
        for(int i = 1; i <= m ;i++)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        memset(max1,0,sizeof(max1));
        for(int i = 1; i <= n; i++){
             max2 = -inf;
            for(int j = i; j <= m; j++){
                   dp[j] = max(dp[j-1]+a[j],max1[j-1]+a[j]);
                   max1[j-1] = max2;
                   max2 = max(max2,dp[j]);
            }
        }
        printf("%d\n",max2);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/zero-begin/p/4523184.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值