题目1143:Primary Arithmetic

题目描述:

    Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty. 

输入:

    Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

输出:

    For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

样例输入:
123 456
555 555
123 594
0 0
样例输出:
NO carry operation.
3 carry operations.
1 carry operation.




如果是NO,最后是没有s的,如果是1,也是没有s的。
其他才是复数形式。万万注意。

Code:
#include <iostream>
 
using namespace std;
 
void Translate(int arr[],unsigned int num,unsigned int &cnt){
    cnt=0;
    while(num!=0){
        int x=num%10;
        arr[cnt++]=x;
        num=num/10;
    }
}
 
int main()
{
    int num_a[20],num_b[20];
    unsigned int a,len_a,b,len_b;
    unsigned int index_a,index_b;
    while(cin>>a>>b){
        if(a==0&&b==0)
            break;
        Translate(num_a,a,len_a);
        Translate(num_b,b,len_b);
        index_a=index_b=0;
        int answer=0,c=0;
        while(index_a<len_a&&index_b<len_b){
            c=(num_a[index_a]+num_b[index_b]+c)/10;
            if(c>0)
                ++answer;
            ++index_a;
            ++index_b;
        }
        if(index_a<len_a){
            while(index_a<len_a){
                c=(num_a[index_a]+c)/10;
                if(c>0)
                    ++answer;
                ++index_a;
            }
        }
        if(index_b<len_b){
            while(index_b<len_b){
                c=(num_b[index_b]+c)/10;
                if(c>0)
                    ++answer;
                ++index_b;
            }
        }
        if(answer==0)
            cout<<"NO carry operation."<<endl;
        else
            if(answer==1)
                cout<<answer<<" carry operation."<<endl;
            else
                cout<<answer<<" carry operations."<<endl;
    }
    return 0;
}
 
/**************************************************************
    Problem: 1143
    User: lcyvino
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1520 kb
****************************************************************/
 
   

 

 


转载于:https://www.cnblogs.com/Murcielago/p/4203930.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值