Poj1845

Sumdiv
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17258 Accepted: 4335

Description

Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).

Input

The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.

Output

The only line of the output will contain S modulo 9901.

Sample Input

2 3

Sample Output

15

Hint

2^3 = 8.
The natural divisors of 8 are: 1,2,4,8. Their sum is 15.
15 modulo 9901 is 15 (that should be output).

 

 

#include<iostream>
#include<cmath>
//#define LL long long
typedef long long LL;
using namespace std;

struct mc{
	LL prime;
	LL count;
}s[10000];

int prime(LL x){
      if(x==2){return 1;}
      if(x<=1 || x%2==0){return 0;}
      LL j=3;
      while(j<=(LL)sqrt(double(x))){
               if(x%j==0){return 0;}
               j=j+2;
              }
      return 1;
    }
    
LL modular(LL a, LL r, LL m){
            LL d=1,t=a;
            while(r>0){
                if(r%2==1){d=d*t%m;}
                 r=r/2;
                 t=t*t%m;
                    }  
        return d;           
      }

int fun(LL a){
	int j=0;
     for(int i=2;i*i<=a;){
	     if(a%i==0){
        	j++;
        	s[j].prime=i;
        	s[j].count=0;
        }
		while(a%i==0){
	      s[j].count++;
	      a=a/i;
		}	
		if(i==2){i++;}else{i=i+2;}
     }
     if(a!=1){
     	j++;
     	s[j].prime=a;
     	s[j].count=1;
     }
     return j;
}              
              
LL gui(LL p,LL n){
	if(n==0){return 1;}
    if(n%2==0){return (  (1+modular(p,n/2+1,9901))*(gui(p,n/2-1)) + modular(p,n/2,9901))%9901;}	
    if(n%2==1){return (  (1+modular(p,n/2+1,9901))*(gui(p,n/2)) )%9901;}	

}

int main(){
    LL a,b,mi,len,ans=1;
    scanf("%I64d%I64d",&a,&b);
    if(a==0){printf("0\n");return 0;}
    mi=modular(a,b,9901);
    //printf("%I64d",mi);
    len=fun(a);
    /*for(int i=1;i<=len;i++){
    	printf("%I64d %I64d\n",s[i].prime,s[i].count);
    }*/
    for(int i=1;i<=len;i++){
      ans=ans*gui(s[i].prime,s[i].count*b)%9901;	
    }
    printf("%I64d",ans);
	system("pause");
	return 0;
    }


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值