HDU 4442 排队贪心

Physical Examination

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 15   Accepted Submission(s) : 6
Problem Description
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
 

Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues). Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue: 1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject. 2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue. The input ends with n = 0. For all test cases, 0<n≤100000, 0≤a[sub]i[/sub],b[sub]i[/sub]<2[sup]31[/sup].
 

Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 

Sample Input
 
  
5 1 2 2 3 3 4 4 5 5 6 0
 

Sample Output
 
  
1419 [hint] In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 120-core-parallel head, and decided that this is the optimal choice. [/hint]

2012京华区域赛题簪2016CSUFT训练赛(4)

题意:每个科目检查时间和等待时间都不同,第一个输入为n种科目检查也就是n个队,比如第一行为1队,1,2,意思是排完1队需要1秒,但排其他队的时候另外的队伍是要等待且队伍变长的,2就是每等待1秒,排完这个队伍的时间增加2秒。要求以最快的时间排完整个队伍。

典型贪心思想,模拟一遍就知道如何贪了,比如1队(a1,b1),2队(a2,b2),先排1队再排二队的总时间是a1+b2*a1+a2,先排2队再排1队的总时间是a2+b1*a2+a1,由此公式可以看出每个队伍的固定排时是一定要加上的,只用比较b2*a1,b1*a2的大小就行了,直接排序即可。

注意的是每次sum的累加都要对MOD取模一次


#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
typedef long long ll;
const int mod = 365*24*60*60;
const int maxn = 100000+10;

struct ee{
    ll t1;
    ll t2;
}e[maxn];

bool cmp(ee a,ee b)
{
    return a.t1*b.t2<a.t2*b.t1;
}

int main(){
    int n,i;
    while(scanf("%d",&n)&&n){
    for(i=0;i<n;i++){
        scanf("%I64d%I64d",&e[i].t1,&e[i].t2);
    }
    sort(e,e+n,cmp);
    ll sum = 0;
    for(i=0;i<n;i++)
     sum = (sum + sum*e[i].t2 + e[i].t1) % mod;

    printf("%I64d\n",sum);
    }
    return 0;
}


转载于:https://www.cnblogs.com/mingrigongchang/p/6246215.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值