hdu4442(模拟+贪心)

Physical Examination

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3646    Accepted Submission(s): 1002


Problem Description
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
 

Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤a i,b i<2 31.
 

Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 

Sample Input
  
  
5 1 2 2 3 3 4 4 5 5 6 0
 

Sample Output
  
  
1419
Hint
In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 120-core-parallel head, and decided that this is the optimal choice.
 

Source
 

Recommend
zhuyuanchen520
         本题模拟医院排队看病,每排一个对都有一个最初等待值ai与附加值bi。若总的时间值为sumi时排第i个队列,此时sumi*bi+ai。本题必定是个贪心问题。我们得观察贪心策略。
         假设1个人,则为sum=ai;
         假设2个人,最省时间的顺序为(1,2),则有a1+a1*b2+a2<a2+a2*b1+a1,可得a1/b1<a2/b2;
         假设3个人,最省时间的序列为(1,2,3),则有a1+(b2*a1+a2)+((a1+(b2*a1+a2))*b3+a3)<a1+(b3*a1+a3)+((a1+(b3*a1+a3))*b2+a2)且
a1+(b2*a1+a2)+((a1+(b2*a1+a2))*b3+a3)<a2+(b1*a2+a1)+((a2+(b1*a2+a1))*b3+a3),可得a1/b1<a2/b2<a3/b3
             ……
         于是猜想若(1,2,3……n)为最佳序列,则有a1/b1<a2/b2<a3/b3……an/bn(充要条件).于是按这个排序即可(注意变形避免分母为0)。
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

const int MAXN=100000+100;
const __int64 Mod=365*24*60*60;
struct node
{
	__int64 a,b;
}Que[MAXN];

bool cmp(node tmpa,node tmpb)
{
	return tmpa.a*tmpb.b<tmpb.a*tmpa.b;
}

int main()
{
	int n,i;
	__int64 sum;
	while(~scanf("%d",&n),n)
	{
		for(i=0;i<n;i++)
			scanf("%I64d%I64d",&Que[i].a,&Que[i].b);

		sort(Que,Que+n,cmp);
		sum=0;
		for(i=0;i<n;i++)
		{
			sum+=sum*Que[i].b;
			sum+=Que[i].a;
			sum%=Mod;
		}
		printf("%I64d\n",sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值