hdu 5533(几何水)

 

Input
The first line contains a integer  T indicating the total number of test cases. Each test case begins with an integer  n, denoting the number of stars in the sky. Following  n lines, each contains  2 integers  xi,yi, describe the coordinates of  n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

 

Sample Input
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

 

Sample Output
NO YES NO

 



题意:给你几个点,问能否形成正多边形。

思路:

①找出所有点之间的最短距离,即边长。然后再在所有点中找出与边长相等的,只要数量为n即

说明能够成正多边形

②要求输入的为整数,所以只有正四边形才能成立,判断下即可


#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
typedef long long ll;
double x[1005];
double y[1005];
double len[1005][1005];

double get_(int i,int j)
{
    return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}

int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        double tmin = 0x3f3f3f3f;
        scanf("%d",&n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%lf%lf",&x[i],&y[i]);
        }
        for(int i = 1; i <= n; i++)
            for(int j = i+1; j <= n; j++)
            {
                len[i][j] = get_(i,j);
                tmin = min(tmin,len[i][j]);
            }
        int num = 0;
        for(int i = 1; i <= n; i++)
            for(int j = i+1; j <= n; j++)
            {
                if(tmin == len[i][j])
                {
                    num++;
                }
            }
        if(num == n)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/Przz/p/5409687.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值