hdu--5533

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 592    Accepted Submission(s): 315


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer  T  indicating the total number of test cases. Each test case begins with an integer  n , denoting the number of stars in the sky. Following  n  lines, each contains  2  integers  xi,yi , describe the coordinates of  n  stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
  
  
NO YES NO
解题思路:在周赛写这一道题时,我想到了正多边形的两点之间最短路径等于他们的边长,但在计算时,竟让忘了重边问题, 敲打.事后又写了一下,要能组成正多边形,那么应该有有n(n==顶点个数)条距离最小且长度相等的不重复的边.代码如下:
#include<stdio.h>
#include<cmath>
#define INF 0x3f3f3f3f
int main(){
	int t,n,m;
	int x[110];
	int y[110];
	double edge[110][110],min,s;
	scanf("%d",&t);
	while(t--){
       	scanf("%d",&n);
		for(int i=1;i<=n;i++){
			scanf("%d%d",&x[i],&y[i]);
		}
		min=INF;
        for(int i=1;i<=n;i++){
        	for(int j=i+1;j<=n;j++){
        		s=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
	    		edge[i][j]=sqrt(s);
                if(edge[i][j]<min)min=edge[i][j];
        	}
    }
    int flag=0;
	for(int i=1;i<=n;i++){
		for(int j=i+1;j<=n;j++){
			if(edge[i][j]==min)
			flag++;
		}
	}
	if(flag==n)printf("YES\n");
	else printf("NO\n");
}
	return 0;
}
</pre><pre name="code" class="cpp">
另一种方法:因为每一个顶点的横纵坐标都是整数,所以只有正四边形满足条件.
代码如下:
<pre name="code" class="cpp">#include<stdio.h>
#include<cmath>
#include<algorithm>
using namespace std;
int main(){
	int t,n,m;
	int x[110];
	int y[110];
	double edge[110];
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			scanf("%d%d",&x[i],&y[i]);
		}
		if(n!=4){
			printf("NO\n");
			continue;
		}
		int k=0;
		double s;
	    for(int i=1;i<=n;i++){
	    	for(int j=i+1;j<=n;j++){
	    	    s=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
	    		edge[k++]=sqrt(s);
	    	}
	    }
	    int flag=1;
	    sort(edge,edge+k);
        s=edge[0];
	    for(int i=1;i<k;i++){
	    	if(edge[i]==s){
	    		flag++;
	    	}
	    }
	    if(flag==n)printf("YES\n");
	    else printf("NO\n");
	}
	return 0;
}





 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值