hdu 1075 map的使用 字符串截取的常用手段 以及string getline 使用起来的注意事项...

首先说字符串的截取套路吧 用坐标一个一个的输入

用遍历的方式逐个去检查字符串中的字符是否为符合的情况 如果是的话 把该字符放入截取string 中 让后坐标前移

如果不是的话 截取结束 坐标初始化

然后是map的使用 头文件为 <map>

定义的话 map<类型,类型> 变量名

对于map中值的传入的话 直接用数组的形式就好

这里由于有搜索 所以还要用到find函数   如果找不到的话 find返回值为end()

再就是string 类型变量的使用要注意 string类型的变量在下次对其更改之前会自动释放自己的内容 

题目

Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

 

Output
In this problem, you have to output the translation of the history book.
 

 

Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

 

Sample Output
hello, i'm from mars. i like earth!
 
先上代码

#include<stdio.h>
#include<map>
#include<string>
#include<iostream>
using namespace std;
int main()
{
 string str,b,d;
 char s[60];
 int i,begin,end,j;
 map<string,string> fuck;
 cin>>str;
 while(cin>>str&&str!="END")
 {
//  if(str=="END") break;
  cin>>b;
  fuck[b]=str;
 }
 cin>>str;
 getchar();///  这里尤其要注意  在用getline和scanf(%c)有点像 对于事先输入的值回车要getchar
 j=0;
 while(getline(cin,str)&&str!="END")
 {
//  if(str=="END") break; 
//        cout<<str<<endl;
  for(i=0;i<str.length();i++)
  {
   if(str[i]>='a'&&str[i]<='z')
            {
               s[j++]=str[i];//  由于string的自动释放  所以用s定义为数组比较好
 //     cout<<s[j-1]<<endl; 
            }
            else
   {
    s[j]='\0';
   // cout<<s<<endl;
    j=0;
    d=s;
    if(fuck.find(d)!=fuck.end())
    {
     cout<<fuck[d];
    }
    else cout<<d;
    cout<<str[i];
   }
  }
  cout<<endl;
 }
 return 0;
}

 

转载于:https://www.cnblogs.com/z1141000271/p/5405472.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值