hdu 1075 What Are You Talking About

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 13108    Accepted Submission(s): 4160


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
 
 
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.


简单的字符串映射,用了map写的。不过之前自己不知道怎么预处理那个“START”,“END”,看了别人的发现了个新东东scanf("%*s");可以读入串,并不用处理串。然后顺序读入那两个串,用mp映射存储。之后的数据直接一行输入,然后新定义一个string保存要检测的字符,得到一个新串。再用find函数,查找mp中是否有映射值。如果存在直接输出映射值,否则输出原串,非字符直接输出。别忘了给mp清空...

代码:

<span style="font-size:14px;">#include<stdio.h>
#include<string.h>
#include<iostream>
#include<cstring>
#include<string>
#include<map>
#define maxn 10000
using namespace std;
map<string,string>mp;
map<string,string>::iterator it;
string a,b;
int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%*s");
    while(cin>>a,a!="END")
        {
            cin>>b;
            mp[b]=a;
        }
    scanf("%*s");
    getchar();
    string s,str;
    while(getline(cin,s),s!="END")
    {
        for(int i=0;i<s.length();i++)
            {
                if(s[i]<'a'||s[i]>'z')
                {
                    it=mp.find(str);
                    if(it!=mp.end())
                        cout<<(*it).second;
                    else
                        cout<<str;
                    cout<<s[i];
                    str="";
                }
                else
                   str+=s[i];
            }
        cout<<endl;
    }
    mp.clear();
    return 0;
}</span>



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值