hdu 6205 card card card 尺取法

card card card

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1774    Accepted Submission(s): 792


Problem Description
As a fan of Doudizhu, WYJ likes collecting playing cards very much. 
One day, MJF takes a stack of cards and talks to him: let's play a game and if you win, you can get all these cards. MJF randomly assigns these cards into  n heaps, arranges in a row, and sets a value on each heap, which is called "penalty value".
Before the game starts, WYJ can move the foremost heap to the end any times. 
After that, WYJ takes the heap of cards one by one, each time he needs to move all cards of the current heap to his hands and face them up, then he turns over some cards and the number of cards he turned is equal to the penaltyvalue.
If at one moment, the number of cards he holds which are face-up is less than the penaltyvalue, then the game ends. And WYJ can get all the cards in his hands (both face-up and face-down).
Your task is to help WYJ maximize the number of cards he can get in the end.So he needs to decide how many heaps that he should move to the end before the game starts. Can you help him find the answer?
MJF also guarantees that the sum of all "penalty value" is exactly equal to the number of all cards.
 

 

Input
There are about  10 test cases ending up with EOF.
For each test case:
the first line is an integer n (1n106), denoting n heaps of cards;
next line contains n integers, the ith integer ai (0ai1000) denoting there are ai cards in ith heap;
then the third line also contains n integers, the ith integer bi (1bi1000) denoting the "penalty value" of ith heap is bi.
 

 

Output
For each test case, print only an integer, denoting the number of piles WYJ needs to move before the game starts. If there are multiple solutions, print the smallest one.
 

 

Sample Input
5
4 6 2 8 4
1 5 7 9 2
 
Sample Output
4
Hint
[pre] For the sample input: + If WYJ doesn't move the cards pile, when the game starts the state of cards is: 4 6 2 8 4 1 5 7 9 2 WYJ can take the first three piles of cards, and during the process, the number of face-up cards is 4-1+6-5+2-7. Then he can't pay the the "penalty value" of the third pile, the game ends. WYJ will get 12 cards. + If WYJ move the first four piles of cards to the end, when the game starts the state of cards is: 4 4 6 2 8 2 1 5 7 9 WYJ can take all the five piles of cards, and during the process, the number of face-up cards is 4-2+4-1+6-5+2-7+8-9. Then he takes all cards, the game ends. WYJ will get 24 cards. It can be improved that the answer is 4. **huge input, please use fastIO.** 
题意:给定一些num以及这些num的value,我们每次都可以把最开头的数字挪到末位去,然后取数字的规则就是拿掉这个数字之后,如果value之和小于num之和,就可以继续取。问我们至少需要挪多长次,可以取最多的num。
题解:既然只能顺序取,那么所有的情况可以把原序列倍增一边之后去遍历所有的情况,由于数据比较大,用尺取法的思想跑一遍就好(需要处理一点细节) 。
ac代码:
#include <cstdio>
#include <iostream>
using namespace std;
int num[2000010];
int v[2000010];
int Scan()
{   //  输入外挂
    int res = 0, flag = 0;
    char ch;
    if ((ch = getchar()) == '-')
    {
        flag = 1;
    }
    else if(ch >= '0' && ch <= '9')
    {
        res = ch - '0';
    }
    while ((ch = getchar()) >= '0' && ch <= '9')
    {
        res = res * 10 + (ch - '0');
    }
    return flag ? -res : res;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            num[i]=Scan();
            num[i+n]=num[i];
        }
        //cout<<num[6]<<endl;
        for(int i=1;i<=n;i++)
        {
            v[i]=Scan();
            v[i+n]=v[i];
        }
        int mx=-1;
        int ret=0;
        int l;
        int r;
        int sumn,sumv,len;
        l=r=len=1;
        sumn=num[l];
        sumv=v[l];
        while(l<=n)
        {
            // 回退?
            while(sumn < sumv && l<r)
            {
                len--;
                sumn-=num[r];
                sumv-=v[r];
                r--;
            }
            while(len<n && sumn >= sumv)
            {
                r++;
                sumn+=num[r];
                sumv+=v[r];
                len++;
            }
           // cout<<r<<' '<<sumn<<endl;
            if(sumn > mx)
            {
                mx=sumn;
                ret=l-1;
            }
            //while( sumn <= sumv)
            sumn-=num[l];
            sumv-=v[l];
            l++;
            len--;
        }
        //cout<<mx<<endl;
        cout<<ret<<endl;
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/z1141000271/p/7561233.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值