ACM Sdut 2158 Hello World!(数学题,排序) (山东省ACM第一届省赛C题)

题目描述

We know thatIvan gives Saya three problems to solve (Problem F), and this is the firstproblem.
We need a programmer to help us for some projects. If you show us that youor one of your friends is able to program, you can pass the first hurdle.
I will give you a problem to solve. Since this is the first hurdle, it is verysimple.

We all know that the simplest program is the
Hello World!program. This is a problem just as simple as the Hello World!
In a large matrix, there are some elements has been marked. For every markedelement, return a marked element whose row and column are larger than theshowed element
s row andcolumn respectively. If there are multiple solutions, return the element whoserow is the smallest; and if there are still multiple solutions, return theelement whose column is the smallest. If there is no solution, return -1 -1.
Saya is not a programmer, so she comes to you for help
Can you solve this problem for her?

输入

The inputconsists of several test cases.
The first line of input in each test case contains one integer N (0<N
1000), which represents the number of marked element.
Each of the next N lines containing two integers r and c,represent the element
s rowand column. You can assume that 0<r,c300. A marked element can be repeatedly showed.
The last case is followed by a line containing one zero.

输出

For each case,print the case number (1, 2 ), andfor each elements rowand column, output the result. Your output format should imitate the sampleoutput. Print a blank line after each test case.

示例输入

3

1 2

2 3

2 3

 

0

示例输出

Case 1:

2 3

-1 -1

-1 -1

 

/************************************

在一个矩阵中有一些标记元素(行 r 和列 c ),找出比这些元素行,列下标大的标记元素的行和列并输出,如果有多个输出行最小的,行相同输出列最小的

简单的数学题,排序,因为每个元素有两个下标(r,c),以行(r)为主排序,若行(r)相同,则比较列(c)..然后判断一下就行。

**************************************/

Code:

#include <stdio.h>
#include<algorithm>
#include <string.h>
using namespace std;
struct Point //  定义一个 元素 (标记) 的结构体。
{
    int x;
    int y;
}point[1005],p[1005];
bool cmp(Point a,Point b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{
    int n,count_case = 1,i,j,k;
    while(scanf("%d",&n)&&n)
    {
        for(i = 0;i<n;i++)
        {
            scanf("%d%d",&point[i].x,&point[i].y);
            p[i].x = point[i].x;p[i].y = point[i].y;// 拷贝一份数据 
        }
        std::sort(p,p+n,cmp);  //  将拷贝数据备份
        printf("Case %d:\n",count_case++);
        for(i = 0;i<n;i++)
        {
            j = 0;
            while((point[i].x>=p[j].x||point[i].y>=p[j].y)&&j<n)//  遍历,如果标记元素 的 x y 比要显示的小 则继续,否则跳出循环
                j++;
            if(j<n)
                printf("%d %d\n",p[j].x,p[j].y);//  找到了比 标记元素 的 x y 大的元素,输出
            else
                printf("-1 -1\n");//  没找到,输出 -1 -1
        }
        printf("\n");
    }
    return 0;
}


posted on 2014-04-13 17:34  CY_ 阅读( ...) 评论( ...) 编辑 收藏

转载于:https://www.cnblogs.com/gray1566/p/3704314.html

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值