蛇形填数

   在n*n方阵里填入1,2,3,…,n*n,要求填成蛇形。例如n=4时方阵为:

    10  11  12  1

     9  16  13  2

     8  15  14  3

     7   6   5  4

解题思路:

我们可以了解到数字的大概规律就是先从上到下,到左,到上,到右这个顺序填写,我们只要注意临界点即可。

//
//  main.cpp
//  c++prime
//
//  Created by SJCHEN on 2019/1/19.
//  Copyright © 2019 SJCHEN. All rights reserved.
//

#include <iostream>
#include <cstdio>
using namespace std;
#define MAXN 10
int a[MAXN][MAXN];

int main()
{
    int n,x,y,tot = 0;
    cin >> n;
    memset(a, 0, sizeof(a));
    tot = a[x = 0][y = n-1] = 1;
    while (tot < n*n) {
        while (x+1 < n && !a[x+1][y]) a[++x][y] = ++tot;//
        while (y-1 >= 0 && !a[x][y-1]) a[x][--y] = ++tot;//
        while (x-1 >= 0 && !a[x-1][y]) a[--x][y] = ++tot;//
        while (y+1 < n && !a[x][y+1]) a[x][++y] = ++tot;//
    }
    for (x = 0; x < n; x++) {
        for (y = 0; y < n; y++)
            printf("%3d",a[x][y]);
        cout << endl;
    }
    return 0;
}

 

poj 3752

http://poj.org/problem?id=3752

Description

给定两个整数M,N,生成一个M*N的矩阵,矩阵中元素取值为A至Z的26个字母中的一个,A在左上角,其余各数按顺时针方向旋转前进,依次递增放置,当超过26时又从A开始填充。例如,当M=5,N=8时,矩阵中的内容如下:
A B C D E F G H

V W X Y Z A B I

U J K L M N C J

T I H G F E D K

S R Q P O N M L
Input

M为行数,N为列数,其中M,N都为大于0的整数。
Output

分行输出相应的结果
Sample Input

4 9
Sample Output

A B C D E F G H I
V W X Y Z A B C J
U J I H G F E D K
T S R Q P O N M L

 

//
//  main.cpp
//  c++prime
//
//  Created by SJCHEN on 2019/1/19.
//  Copyright © 2019 SJCHEN. All rights reserved.
//

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define MAXN 1000
int a[MAXN][MAXN];

int main()
{
    int n,m,x,y,tot = 1;
    char c;
    cin >> m >> n;
    memset(a, 0, sizeof(a));
    c = 'A';
    a[x=0][y=0] = 'A';
    while (tot < n*m) {
        while (y + 1 < n && !a[x][y+1]) {
            if (c >= 90)
                c = c - 26;
            a[x][++y] = ++c;
            tot++;
        }
        while (x+1 < m && !a[x+1][y]) {
            if (c >= 90)
                c = c - 26;
            a[++x][y] = ++c;
            tot++;
        }
        while (y-1>=0 && !a[x][y-1]) {
            if (c >= 90)
                c = c - 26;
            a[x][--y] = ++c;
            tot++;
        }
        while (x-1 > 0 && !a[x-1][y]) {
            if (c >= 90)
                c = c - 26;
            a[--x][y] = ++c;
            tot++;
        }
    }
    for (x = 0; x < m; x++) {
        for (y = 0; y < n; y++) {
            printf("%3c", a[x][y]);
        }
        cout << endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/SJCHEN/p/10542708.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值