【UVA 11078】BUPT 2015 newbie practice #2 div2-A -Open Credit System

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=102419#problem/A

In an open credit system, the students can choose any course they like, but there is a problem. Some of the students are more senior than other students. The professor of such a course has found quite a number of such students who came from senior classes (as if they came to attend the pre requisite course after passing an advanced course). But he wants to do justice to the new students. So, he is going to take a placement test (basically an IQ test) to assess the level of difference among the students. He wants to know the maximum amount of score that a senior student gets more than any junior student. For example, if a senior student gets 80 and a junior student gets 70, then this amount is 10. Be careful that we don’t want the absolute value. Help the professor to figure out a solution. Input Input consists of a number of test cases T (less than 20). Each case starts with an integer n which is the number of students in the course. This value can be as large as 100,000 and as low as 2. Next n lines contain n integers where the i’th integer is the score of the i’th student. All these integers have absolute values less than 150000. If i < j, then i’th student is senior to the j’th student. Output For each test case, output the desired number in a new line. Follow the format shown in sample input-output section. Sample Input 3 2 100 20 4 4 3 2 1 4 1 2 3 4 Sample Output 80 3 -1

题意:给出一串数字,先出现的与后出现的数的最大差值是多少,有t组(少于20)数据,每组最多100,000个数,这些数绝对值小于150000。

题解:每组的n个数,读入的第一个数作为maxn,表示当前出现的最大数,接下来每读一个数,看看用maxn(前面最大的数)减去a(当前数)是否比ans(之前的计算的最大差值)更大,ans=max(ans,maxn-a),然后比较a是否比maxn大,maxn=max(maxn,a)

代码:

#include<cstdio>
#include<algorithm>

#define mm=100005;

using namespace std;

int t,n,a,ans,maxn;
int main(){
    scanf("%d",&t);
    while(t--){
        ans=-150005;
        scanf("%d",&n);
        scanf("%d",&maxn);
        for(int i=1;i<n;i++)
        {
            scanf("%d",&a);
            ans=max(maxn-a,ans);
            maxn=max(a,maxn);
        }
        printf("%d\n",ans);
    }
}

 

 

 

  

转载于:https://www.cnblogs.com/flipped/p/5102781.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值