poj 3664

Election Time

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 7390

Accepted: 4000

Description

The cows are having their first electionafter overthrowing the tyrannical Farmer John, and Bessie is one of N cows(1 ≤ N ≤ 50,000) running for President. Before the electionactually happens, however, Bessie wants to determine who has the best chance ofwinning.

The election consists of two rounds. Inthe first round, the K cows (1 ≤ K ≤ N)cows with the most votes advance to the second round. In the second round, thecow with the most votes becomes President.

Given that cow i expectsto get Ai votes (1 ≤ Ai ≤1,000,000,000) in the first round and Bi votes (1 ≤ Bi ≤1,000,000,000) in the second round (if he or she makes it), determine which cowis expected to win the election. Happily for you, no vote count appears twicein the Ai list; likewise, no vote count appearstwice in the Bi list.

Input

* Line 1: Two space-separated integers: N and K 
* Lines 2..N+1: Line i+1 contains two space-separated integers: Ai and Bi

Output

* Line 1: The index of the cow that isexpected to win the election.

Sample Input

5 3

3 10

9 2

5 6

8 4

6 5

Sample Output

5

 

解题思路:这道题目的题意很好理解,就是将头牛先根据Ai值从大到小排序,取出前K头Ai值大的牛,再根据这K头牛Bi的值,将它们从大到小排序,输出Bi值最大的那头牛的原始序号值。有关排序可以直接使用C++中的sort函数,难点在于,两次排序以及原始序号值的记录,这就需要使用到结构体。

 

源代码:


#inlcude<iostream>

#include<stdio.h>

#include<algorithm>

using namespace std;

struct vote

{

         intA;

         intB;

         intnum;

}cow[50001];

int cmp1(vote cow1,vote cow2)

{

         returncow1.A>cow2.A;

}

int cmp2(vote cow1,vote cow2)

{

         returncow1.B>cow2.B;

}

int main()

{

         intn,k,i;

         vote cow[50001];

         scanf("%d%d",&n,&k);

         for(i=0;i<n;i++)

         {

                   scanf("%d%d",&cow[i].A,&cow[i].B);

                   cow[i].num=i+1;

         }

         sort(cow,cow+n,cmp1);

         sort(cow,cow+k,cmp2);

         printf("%d\n",cow[0].num);

         return0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值