POJ 2528 Mayor's posters 区间离散化线段树


Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45894 Accepted: 13290

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source


给你n张画报要贴在墙上,后面贴上去的会覆盖前面贴上去的,求最后能够看见多少张画报。
题目给的区间最大是10000000,所以需要将区间离散化一下,然后线段树求解。
//35616K	94MS
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 10007
using namespace std;
int id[M*2],_hash[10000007];
int n,num;
struct T
{
    int left,right,mid,color;
    T(){color=0;}
}tree[M<<4];
struct P
{
    int l,r;
}p[M*8];
void build(int l,int r,int i)
{
    tree[i].left=l;tree[i].right=r;
    tree[i].mid=(l+r)>>1;tree[i].color=0;
    if(l==r)return;
    build(l,tree[i].mid,i<<1);
    build(tree[i].mid+1,r,i<<1|1);
}
bool query(int l,int r,int i)
{
    bool flag;
    if(tree[i].color)return false;
    if(tree[i].left==l&&tree[i].right==r)
    {
        tree[i].color=true;
        return true;
    }
    if(r<=tree[i].mid)flag=query(l,r,i<<1);
    else if(l>tree[i].mid)flag=query(l,r,i<<1|1);
    else
    {
        bool flag1=query(l,tree[i].mid,i<<1);
        bool flag2=query(tree[i].mid+1,r,i<<1|1);
        flag=flag1||flag2;
    }
    if(tree[i<<1].color&&tree[i<<1|1].color)//反馈原节点
        tree[i].color=true;
    return flag;
}
void lisanhua()
{
    sort(id,id+num);
    num=unique(id,id+num)-id;
    for(int i=0;i<num;i++)
        _hash[id[i]]=i;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        num=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&p[i].l,&p[i].r);
            id[num++]=p[i].l;
            id[num++]=p[i].r;
        }
        lisanhua();
        build(0,num-1,1);
        int count=0;
        for(int i=n;i>=1;i--)//从最后贴的往前找
        {
            if(query(_hash[p[i].l],_hash[p[i].r],1))
                count++;
        }
        printf("%d\n",count);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值